[beta] Asuswrt-Merlin 384.17 beta is out

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.
Status
Not open for further replies.

RMerlin

Asuswrt-Merlin dev
Howdy folks,

This will be just a quick test run to ensure that nothing is broken, as I'd like to push this release out within a few days. Normally I would have made it just a point release, but since I had already bumped the revision to 384.17, it was faster for me to just push it as-is rather than fork out and cherry-pick a couple of fixes.

It contains only a couple of updates, including an OpenSSL security update that affects TLS 1.3.

I have uploaded the files to the test build folders:

http://www.asuswrt-merlin.net/test-builds

The list of changes:

Code:
384.17 (xx-xxx-xxxx)
  - NEW: Add Chacha20-poly1305 support to dropbear (themiron)
  - UPDATED: dnsmasq to 2.81-openssl (themiron)
  - UPDATED: openvpn to 2.4.9.
  - UPDATED: curl to 7.69.1.
  - UPDATED: openssl-1.1 to 1.1.1g (themiron)
  - UPDATED: nano to 4.9.2.
  - FIXED: RT-AC88U/RT-AC3100/RT-AC5300 could fail to upgrade
           from newer stock versions to Asuswrt-Merlin.
  - FIXED: Various webui issues with sorting DHCP reservations.


384.13_7 (xx-xxx-xxxx)
  This release is only available for the RT-AC87U and RT-AC3200.

  - UPDATED: dnsmasq to 2.81-openssl (themiron)
  - UPDATED: openvpn to 2.4.9.
  - UPDATED: openssl-1.1 to 1.1.1g (themiron)
Please confirm that everything is still working properly (and don't forget to mention which router model you tested).
 

thelonelycoder

Part of the Furniture
I have a theme update for amtm, will post a pull request tonight.
 

RMerlin

Asuswrt-Merlin dev
I have a theme update for amtm, will post a pull request tonight.
Make sure you are 100% positive that it won't break anything, as I intend to push final releases as early as this weekend. Otherwise, best to hold off for 384.18.
 

Zastoff

Very Senior Member
Smooth update on 87u to 384.13_7
Thanks RMerlin :)
 

joe scian

Senior Member
Make sure you are 100% positive that it won't break anything, as I intend to push final releases as early as this weekend. Otherwise, best to hold off for 384.18.

RT-AC5300 working fine after upgrading to Beta 1
 

L&LD

Part of the Furniture
RT-AX88U updated from 384.16_0 with almost 12 days uptime.

I did not reboot before upgrading. Rather, I simply safely removed USB drive (signature has the scripts I use) but left the USB drive attached to the router.

Downloaded, verified, and flashed 384.17 Beta 1.

Life is fine and so is the router/network. @RMerlin, thank you. :)

Edit.

Forgot to mention, at about 32 minutes uptime after the upgrade, I rebooted the router.

I just finished rebooting it again after an additional 1.5 hours.

(The reboot times above are normally at about 15 minutes and at just over 1 hour, but I am a little busy right now). :)
 
Last edited:

LimJK

Senior Member
Dirty Flash 384.17_beta1 over 384.16, all seems good:)
  • I have AiMesh Router (AX88U) + 2x AiMesh Nodes (AC86U)
  • Using Fixed WiFi Control Channel & bandwidth: 2.4GHz: Ch 11 20MHz, 5.0GHz: Ch 149 80MHz, no problem so far
  • GUI - I have AiProtection, Asus DDNS (Let's Encrypt), OpenVPN Server configured
  • Scripts - Amtm, Diversion, Skynet, Unbound Manager, connmon
Thanks You!
 

el pescador

Senior Member
RT-AX88U updated from 384.16_0 with almost 12 days uptime.

I did not reboot before upgrading. Rather, I simply safely removed USB drive (signature has the scripts I use) but left the USB drive attached to the router.

Downloaded, verified, and flashed 384.17 Beta 1.

Life is fine and so is the router/network. @RMerlin, thank you. :)

Edit.

Forgot to mention, at about 32 minutes uptime after the upgrade, I rebooted the router.

I just finished rebooting it again after an additional 1.5 hours.

(The reboot times above are normally at about 15 minutes and at just over 1 hour, but I am a little busy right now). :)
Hello mate.
Whats the procedure if i do a clean flash?
 

SheikhSheikha

Regular Contributor
384.17_beta1 causes a problem with L2TP VPN Client.
On boot the L2TP VPN Client kicks in as normal. When changing the client node internet access is blocked even though the client demonstrates to be active (checkmark). Turning off the VPN client gives non-VPN access to the web (it gives non VPN traffic) but turning on the VPN Client causes all traffic to be blocked again. Only a reboot of the router will let this other Node kick in. Switching Node after this reboot causes the blocking to start all over again.
I have extensively tried several scenario's but as soon as I moved back to 384.16 the L2TP VPN client worked normal again .............
 
Last edited:
  • Like
Reactions: a5m

octopus

Very Senior Member
Just updated to 384.17_beta1
Seems curl not working as is should, get "curl error 27" when trying to send mail with curl.
Never get it before. - UPDATED: curl to 7.69.1.

Flashed back to 384.16_0 and it's working again.......:p

Code:
CURLE_OUT_OF_MEMORY (27)
A memory allocation request failed. This is serious badness and things are severely screwed up if this ever occurs.
@RMerlin
 
Last edited:

shawnpear

Occasional Visitor
Hey guys, can anyone help me out with this issue.

i'm using OpenDNS via my laptop network adapter settings, how can i connect to my Router via WiFi?

the usual ip addresses like 192 dont work, and router.asus.com doesn't work as well.
the only way is to "turn off" OpenDNS and then login to the router.
 

Mutzli

Very Senior Member
Also no issues here.
 
Status
Not open for further replies.

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top