Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Bitdefender & Firefox

Discussion in 'Asuswrt-Merlin' started by Miguel Santa, Mar 19, 2017.

  1. Miguel Santa

    Miguel Santa Occasional Visitor

    Joined:
    Jul 27, 2016
    Messages:
    33
    Location:
    Merrick, NY
    Hi everyone,

    I just noticed that everytime I log into my AC5300 router with Firefox, I get an alert from Firefox telling me that the site is not secure and my log in can be compromised. So I type my user name and password and go to manage my router and then evry time I click on any link in my router, Bitdefender shows an alert that a Trojan virus was deleted. This behavior never happened before and it doesn't happen with any of the other browsers. I have a Mac Pro running Mac OS X 10.12.3, Firefox 52.0.2. I ran a scan and even reset the router and still the annoying alerts. Does anyone exhibit this kind of behavior? Screen Shot 2017-03-19 at 9.46.49 PM.png Screen Shot 2017-03-19 at 9.47.35 PM.png
     
  2. bbunge

    bbunge Regular Contributor

    Joined:
    Aug 11, 2014
    Messages:
    189
    New Firefox feature to bug you to death. Change the router to https, turn the feature off in Firefox, or live with it.
     
  3. Sanna1967

    Sanna1967 Very Senior Member

    Joined:
    Apr 1, 2014
    Messages:
    558
    Location:
    Canada
    yes
    Its new with firefox 52 and it is just a new security feature
     
  4. swetoast

    swetoast Very Senior Member

    Joined:
    Apr 12, 2016
    Messages:
    512
    "Security"

    as for bitdefender update the signatures or report a false positive
     
  5. Blinkyz

    Blinkyz Senior Member

    Joined:
    Mar 11, 2015
    Messages:
    264
    Location:
    At work
    Eset Smart Security here with FF52 and NO False positive!
     
  6. tsunami2311

    tsunami2311 Senior Member

    Joined:
    Apr 25, 2013
    Messages:
    351
    security.insecure_field_warning.contextual.enabled;false

    Assuming your refering to above, cause its only thing that turns that warning off, I do have to thank you though, Until I read the part of "turn it off" I didnt think to looking about:config to see if there was way to turn that message off

    Seeing as I made 2 trips to look at other computers using FF/CF doing same things just to realize it some thing FF does now I was annoyed

    Not sure why FF has a "learn more" link for it that goes to no existant page though

    BTW I dont the virus notifaction either. FF/CF 52 with Avast
     
    Last edited: Mar 20, 2017 at 12:21 PM
  7. Sanna1967

    Sanna1967 Very Senior Member

    Joined:
    Apr 1, 2014
    Messages:
    558
    Location:
    Canada
    Here's why :
    Strict Secure Cookies specification implemented in Firefox 52
    The Strict Secure Cookies specification has been implemented. It prevents insecure (read HTTP) sites from setting cookies with the secure flag. It prevents HTTP sites from overwriting cookies set by HTTPS sites with the secure flag.

    http://www.ghacks.net/2017/03/07/firefox-52-0-released-find-out-what-is-new/

    *No false positive : Nod32
     
    Last edited: Mar 20, 2017 at 7:34 PM
  8. Miguel Santa

    Miguel Santa Occasional Visitor

    Joined:
    Jul 27, 2016
    Messages:
    33
    Location:
    Merrick, NY
    I solved the problem by excluding Firefox profile folder from Bitdefender scans. Thanks guys.
     
    Sanna1967 likes this.

Share This Page