Bonehead mistake with jffs config file

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

undecimo

New Around Here
Hi all, I've been running Merlin firmware for years on various products and currently have the latest build on an AX-58U. Instead of assigning static LAN IPs through the GUI, I've been doing it in /jffs/configs/dnsmasq.conf.add.

Last night I made a bonehead mistake - I was entering a new MAC address in the above file and substituted semicolons for colons twice. When I restarted dnsmasq the router began to choke (wouldn't resolve any addresses) but I was able to ssh in and fix one of the semicolons - I didn't notice the second. Then I rebooted the router. Since then, the router still advertises SSIDs, but the DHCP server is hosed and won't issue any IP addresses upon connecting via Wi-Fi or Ethernet.

I have a feeling a factory reset is in my future, but I'm wondering if there's any way I can fire up one more command line session (without serial port surgery) to fix that one problematic character. I have a 3-month-old backup of jffs but never backed up the rest of the router config. Any ideas would be appreciated.
 

ColinTaylor

Part of the Furniture
Just configure the network card on your PC with a static IP address instead of using DHCP.
 

undecimo

New Around Here
Just configure the network card on your PC with a static IP address instead of using DHCP.
I thought I tried that unsuccessfully last night in the wee hours, but with your prompting I tried again and was able to get back in and fix the issue. Thank you!
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top