bonjour and Zenwifi AX

Dd852

New Around Here
I recently switched to a Zenwifi mesh system (3xXT-8) and I'm very happy except that Bonjour discovery seems very slow across the mesh. I run an all Apple home. Finding the Airprint printer takes forever. Using the Apple Music remote app often can't find the itunes library for many minutes if I'm connected to a different node than the library itself.

Are there any settings that others have found that work well to solve this?

I used to be on an Orbi system, which had huge faults to the extent that I could no longer use it, but at least in terms of Bonjour discovery across satellites through the mesh it seemed better.
 

KingBravery

Senior Member
Find 'Airtime Fairness' and disable it.

You can follow my setting too if you want.

JPG_2178.jpg
 

OzarkEdge

Part of the Furniture
Your settings a/solved my problem and b/sped up my whole network. Interesting!

Those changes from current defaults are disable Roaming Assistant, Explicit Beamforming, and Universal Beamforming.

Try leaving Explicit Beamforming enabled and see how it performs... it can improve connections where supported.

OE
 
Last edited:

KingBravery

Senior Member
Your settings a/solved my problem and b/sped up my whole network. Interesting!
Nice to hear that.. Enjoy your speed..
 

KingBravery

Senior Member
One additional thing that I tested recently, If you have device that tend to lost connectivity even the wifi logo still shows connected, you may disable Target Wake Time (TWT). You may feel connection become a bit faster too.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top