[BUG] [ Asuswrt-Merlin 384.19 | RT-AX88U] Bug in Static-DHCP list

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

HOgi

New Around Here
There seems to be a bug in the latest Asuswrt-Merlin 384.19 firmware for Asus RT-AX88U.

In the Static-DHCP list I created, sometimes devices I named with special terms and icons shows up as "New device" with the default icon. The rest (assigned IP- and MAC-addresses) are fine. The devices this concerns are mostly the same but also change from time to time. After some relouds of the website in the browser, sometimes the original name and icon appear again. Very strage! I allready tried to delete an reenter some of the affected entries, but this doesn't help. Also tried different browsers. Seems to be a firmware bug.

Anybody else have this problem? I have 64 devices in this list. Should be no problem.
NVRAM usage: 74140 / 131072 bytes.

HOgi

PS: Is there any place i officially can report this bug?
 

Attachments

Last edited:

L&LD

Part of the Furniture
How are you using a browser to access network client devices?

Btw, you just did report it officially. :)
 

HOgi

New Around Here
How are you using a browser to access network client devices?

Btw, you just did report it officially. :)
Sorry, don't understand the question. I am talking about the web-interface of the router (LAN -> DHCP Server -> Manually Assigned IP around the DHCP list).
 

intr0

Occasional Visitor
There seems to be a bug in the latest Asuswrt-Merlin 384.19 firmware for Asus RT-AX88U.

In the Static-DHCP list I created, sometimes devices I named with special terms and icons shows up as "New device" with the default icon. The rest (assigned IP- and MAC-addresses) are fine. The devices this concerns are mostly the same but also change from time to time. After some relouds of the website in the browser, sometimes the original name and icon appear again. Very strage! I allready tried to delete an reenter some of the affected entries, but this doesn't help. Also tried different browsers. Seems to be a firmware bug.

Anybody else have this problem? I have 64 devices in this list. Should be no problem.

HOgi

PS: Is there any place i officially can report this bug?
I see you've got Apple devices. If you're running iOS 14+, the OS now uses random MAC addresses (called a private address by Apple). My own device used to change its MAC address fairly frequently when running an earlier developer beta. Now that it's matured a bit, I've not encountered the issue. I hope this is helpful for you.
 

HOgi

New Around Here
I see you've got Apple devices. If you're running iOS 14+, the OS now uses random MAC addresses (called a private address by Apple). My own device used to change its MAC address fairly frequently when running an earlier developer beta. Now that it's matured a bit, I've not encountered the issue. I hope this is helpful for you.
Thanks for your reply. I didn't know this with the changing MAC addresses on Apple devices running iOS 14+. Is there any way to switch this incredible "feature" off?

Regarding the bug: This happens with non Apple devices that all have fixed MAC addresses.
 

intr0

Occasional Visitor
@HOgi Settings > Wifi > Private Address switch on/off.
 

LimJK

Senior Member
Hm... can't find this switch...
Settings -> WiFi -> (Your selected SSID) -> click the blue info icon -> then you see the screen shot the intr0 posted :)
 

HOgi

New Around Here
Now I try to add a new device and it complitly didn't appear in the static dhcp list. :(
If I try to add it a second time, an error messages appears, telling me, that the device is allready in the list, but it didn't show up. Now i can neither edit nor delete the device.

Is there any other way to access the static dhcp list, maybe via ssh?

I hope there is a fix for this bug asap. Last firmware release is more than 3 months old.
 

kernol

Very Senior Member
@HOgi - I don't believe this is a bug in the Merlin firmware at all - simply because LOTS of folk have AX88U routers running Merlin 384.19 and none have reported the problem you are experiencing - or commented in posts to your thread.

Firstly - make sure straight after adding or editing an entry on the LAN- DHCP Server webui page you hit the + button [if adding] and then the APPLY button at the bottom of the page [scroll as much as needed to find it];

Secondly - make sure all IOS devices have "Private" setting turned off - and note that the latest Android version ALSO has adopted the Random MAC address concept. You will have to go to Advanced settings in the WiFi settings to find the option to "Use device MAC" instead of randomised. Windows 10 may well be going down this road as well with WiFi in laptops ??

Finally - go back to the client device and do NOT set a static ip - rather tell it to get its ip from the DHCP server.

If all that fails - time to do a full Factory Reset and rebuild all settings from scratch WITHOUT restoring any settings from a backup.
@L&LD has several guides on how to do the rebuild properly ....
https://www.snbforums.com/threads/major-issues-w-rt-ac86u.56342/page-4#post-495710
https://www.snbforums.com/threads/n...l-and-manual-configuration.27115/#post-205573

or just browse the many others in his About page of his profile ...
https://www.snbforums.com/members/l-ld.24423/#about

Hope you get your problem sorted. :)
 

HOgi

New Around Here
@HOgi - I don't believe this is a bug in the Merlin firmware at all - simply because LOTS of folk have AX88U routers running Merlin 384.19 and none have reported the problem you are experiencing - or commented in posts to your thread.

Firstly - make sure straight after adding or editing an entry on the LAN- DHCP Server webui page you hit the + button [if adding] and then the APPLY button at the bottom of the page [scroll as much as needed to find it];

Secondly - make sure all IOS devices have "Private" setting turned off - and note that the latest Android version ALSO has adopted the Random MAC address concept. You will have to go to Advanced settings in the WiFi settings to find the option to "Use device MAC" instead of randomised. Windows 10 may well be going down this road as well with WiFi in laptops ??

Finally - go back to the client device and do NOT set a static ip - rather tell it to get its ip from the DHCP server.

If all that fails - time to do a full Factory Reset and rebuild all settings from scratch WITHOUT restoring any settings from a backup.
@L&LD has several guides on how to do the rebuild properly ....
https://www.snbforums.com/threads/major-issues-w-rt-ac86u.56342/page-4#post-495710
https://www.snbforums.com/threads/n...l-and-manual-configuration.27115/#post-205573

or just browse the many others in his About page of his profile ...
https://www.snbforums.com/members/l-ld.24423/#about

Hope you get your problem sorted. :)
@kernol

Thank's for your reply.

1. I now have 65 devices in this list. Believe me: I know how to add or edit a device. ;)

2. I only have some iOS devices with this private/random MAC address feature. This feature has been deactivated for all this devices. Anyway, this should not have any effect to the static dhcp list. Think it over! If a device changes it MAC address, the only effect is, that it would be handeled as a new device with a unknown MAC address. It gets a free random IP address within the defined IP address range from the DHCP server. That's it. It did not appear in the list and does not explain the behavior described above. Especially it does not explain, why random entries sometimes appear as "New device" with the default icon and seconds later (after a few reloads of the website), they show up with the original name and icon I assigned again. It also did not explain, why devices I added don't show up in the list like I described in my last post above (yes, I hit the + and the apply button).

3. Of cause no device has a static IP address. They are all set to get its ip from the DHCP server.

Sorry, but I really think this must be a bug.

I allready had problems with an Asus RT-AC68U and the static DHCP list before. Also with Merlin firmware. Entries simply disappear and the reason was that NVRAM run out of space. This is why I upgraded to the AX88U, which has more NVRAM. Usage now: 74140 of 131072 bytes.

I don't know why no one else reported this "bug". Maybe there are no or not many useres with such a long static DHCP list like mine with 65 entries. I setup the router from scratch a few weeks ago and also had no problems until now where the list gets bigger and bigger.

/Edit: Funny thing. Now my last added device suddenly appears in the list. But there are still random devices that I named with special terms and icons show up as "New device" with the default icon and after every reload of the website the devices showing this behavior are changing.. :D
 
Last edited:

john9527

Part of the Furniture
I allready had problems with an Asus RT-AC68U and the static DHCP list before. Also with Merlin firmware. Entries simply disappear and the reason was that NVRAM run out of space. This is why I upgraded to the AX88U, which has more NVRAM. Usage now: 74140 of 131072 bytes.
On the newer routers the size of the dhcp static list is no longer limited by the size of NVRAM.....it's limited by the total number of characters for all the entries (Broadcom limitation). To add more, you need to use a dnsmasq.conf.add (there are examples if you do a search).

@RMerlin - Since this keeps coming up, does it make sense to add some type of warning based on the char count?
 

RMerlin

Asuswrt-Merlin dev
@RMerlin - Since this keeps coming up, does it make sense to add some type of warning based on the char count?
I thought I did, unless it was for another page, or it got lost at some point in a GPL merge.
 

HOgi

New Around Here
On the newer routers the size of the dhcp static list is no longer limited by the size of NVRAM.....it's limited by the total number of characters for all the entries (Broadcom limitation). To add more, you need to use a dnsmasq.conf.add (there are examples if you do a search).

@RMerlin - Since this keeps coming up, does it make sense to add some type of warning based on the char count?
OK, here is what I have done.

1. I enabled JFFS custom scripts and configs
2. I enabled SSH
3. Via SSH I created a file named dnsmasq.conf.add in /jffs/configs/

4. I chmod 755 /jffs/configs/dnsmasq.conf.add to make it executable
(I don't think this is necessary)

5. I add all my dhcp static leases in the format:
dhcp-host=49:EF:0C:24:7F:16,D-Link-AP,192.168.2.10,1440
to this file.

6. I disabled manual assignment of DHCP leases
7. I reboot the router

Is that correct?
Is there any way to check if the configuration works as intended?
Do I have to recreate the file (dnsmasq.conf.add) after a firmware update or not?
Can I delete all entrys in the Web GUI at Advanced_DHCP_Content.asp?
 
Last edited:

dave14305

Part of the Furniture
Lease time defaults to seconds, so you may want 86400 instead of 1440.
 

dave14305

Part of the Furniture
Are you sure? This website says, lease time has to be set in minutes (1440 default).
I wouldn’t bet my life on it but I took it from the dnsmasq man page.
Enable the DHCP server. Addresses will be given out from the range <start-addr> to <end-addr> and from statically defined addresses given in --dhcp-host options. If the lease time is given, then leases will be given for that length of time. The lease time is in seconds, or minutes (eg 45m) or hours (eg 1h) or "infinite". If not given, the default lease time is one hour for IPv4 and one day for IPv6. The minimum lease time is two minutes.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top