Bugs in Release 386.1 [RESOLVED]

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

copperhead

Occasional Visitor
Router: Asus GT-AC2900
Previously Installed Official Asus Firmware: 3.0.0.4.386.41793
Currently Installed Firmware: Merlin GT-AC2900_386.1_0

1. Adaptive QoS | Internet Speed
* Tap GO
* Error message: Notice - Failed to complete the Internet speed test . Please check your internet status at Network Map
* Network Map shows - Internet Status: Connected

2. Wireless | Wifi Radar

* 404 Not Found - url: http://router.asus.com/WiFi_Insight.asp
* Note: Navigating directly to these Wifi Radar linked pages works fine: http://router.asus.com/visindex.asp OR http://router.asus.com/channelcapacity.asp

3. Wireless | General
* Check ON "Enable 160 Mhz" then Apply will not remain checked after page refresh.
* Selecting Channel Bandwidth 160 Mhz then Apply will not remain as 160 Mhz but will return to 20/40/80 Mhz
* Router is incapable of selecting and using 160 Mhz channel bandwidth.
* Note: The official firmware works fine for all of the above

4. LAN | DHCP Server | Manually Assigned IP
* Step 1: Create an entry
* Step 2: From the newly added item tap the default icon within the list view
* Step 3: Tap "Change"
* Step 4: Tap "+" to reveal the Open Dialog
* Step 5: Select any local image (ie. .PNG) and Open
* The selected local image will not change the default router icon. Only the built-in router icons can be used.

Update: I opened some Git Issues.
 
Last edited:

Mutzli

Very Senior Member
Empty your browser cache, reset the router after you update the firmware and format the jffs partition should take care of your issues.
 

RMerlin

Asuswrt-Merlin dev
2) and 3) are probably related to the build profile being out of sync with upstream. I've resynced most models last week, I haven't had time to do it for the GT-AC2900 yet.
 

JIPG

Regular Contributor
2) and 3) are probably related to the build profile being out of sync with upstream. I've resynced most models last week, I haven't had time to do it for the GT-AC2900 yet.
Sorry, does this mean that we should dowload FW 386.1 again and reflash, or it is for new 386.2 alpha?
 

RMerlin

Asuswrt-Merlin dev
Sorry, does this mean that we should dowload FW 386.1 again and reflash, or it is for new 386.2 alpha?
It means you will have to wait for a release that contains the fixes.
 

JIPG

Regular Contributor
Thank you for the clarification. The word "resynced"misleaded me.
 

RMerlin

Asuswrt-Merlin dev
Thank you for the clarification. The word "resynced"misleaded me.
That was meant at the code level. My repo was missing some of the options that were set in Asus's own code, so I went through each build profiles to make sure they were the same as in Asus's GPL, adding the missing ones.
 

copperhead

Occasional Visitor
All listed bugs above have been resolved in the latest pre-beta GT-AC2900_386.2_alpha1-g18f27b0693. Thank you.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top