1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Can someone guide me on how to install Diversion on my Asus 87U?

Discussion in 'Asuswrt-Merlin' started by claudiu911, Apr 23, 2019.

  1. claudiu911

    claudiu911 New Around Here

    Joined:
    Apr 23, 2019
    Messages:
    7
    Okay, so I followed the install guide step by step, but I cannot format the flash drive to ext.
    My router has the latest Merlin FW: Firmware Version 384.10_2 Firmware Build Wed Apr 3 22:29:21 UTC 2019 [email protected]

    I keep receiving this error:
    "
    Formatting /tmp/mnt/UNTITLED now!

    Unmounting device(s)

    umount: can't unmount /tmp/mnt/UNTITLED: Device or resource busy

    Filesystem(s) did not unmount

    See error above for reason
    "

    Any thoughts?
     

    Attached Files:

  2. jsbeddow

    jsbeddow Regular Contributor

    Joined:
    Oct 21, 2016
    Messages:
    87
    Location:
    SF Bay Area
    Which install guide did you follow? The newest one for installing amtm (by L&LD) is very complete and easy to follow: this is the one you should use to then follow up by installing Diversion (and possibly other useful scripts) within the menu system of amtm.

    Edit: more specifically in your case: you might try using the unmount tool in the router GUI first (click the USB icon on the main opening page for options to unmount).
     
    heysoundude likes this.
  3. martinr

    martinr Very Senior Member

    Joined:
    Nov 27, 2014
    Messages:
    1,810
    Location:
    United Kingdom
  4. claudiu911

    claudiu911 New Around Here

    Joined:
    Apr 23, 2019
    Messages:
    7
    I have no problem flashing the script to the router, but I cannot install division on the flash drive.

    Is this the latest guide?
     
  5. skeal

    skeal Part of the Furniture

    Joined:
    Apr 30, 2016
    Messages:
    3,080
    Location:
    /etc
  6. claudiu911

    claudiu911 New Around Here

    Joined:
    Apr 23, 2019
    Messages:
    7
    Same error "
    Formatting /tmp/mnt/untitled now!


    Unmounting device(s)

    umount: can't unmount /tmp/mnt/untitled: Device or resource busy


    Filesystem(s) did not unmount

    See error above for reason"

    I did it step by step (apart from "Enable SSH to 'LAN Only'"), unfortunately, my mbp dosen't have an ethernet port...

    Anyways, I'm done with it. I'll try tomato custom fw, I think it has an integrated adblock.
     
  7. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,111

    I may be missing something here, but your MBP doesn't need an Ethernet port to enable the 'SSH to 'LAN Only' option. ;)

    Did you try formatting the USB drive on a computer first?
     
  8. claudiu911

    claudiu911 New Around Here

    Joined:
    Apr 23, 2019
    Messages:
    7
    If I enable ssh to LAN only I won't be able to ssh into my router from Wi-Fi, and again, my laptop can't connect through lan.

    I formatted the flash drive to NTFS, then FAT, that didn't work (I tried it with multiple flash thumbs... same outcome.).
    Nothing works, yesterday I made a Linux VM, and I formatted the drive to ext, that didn't work at all, when I try to install division, it says: "
    [ Error ] No compatible device(s) found to install

    Diversion on.

    A permanently plugged in USB storage device

    formatted with one of these file systems

    is required: ext2, ext3, ext4"

    I think there must be something wrong with my router, or maybe I'm a bit idiot and I do something wrong.
     
  9. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,111

    Yes, you will be able to SSH to your router when setting to LAN only. What is it set to now?

    Please follow the guide in the link below. I am not really sure what you're doing and where, but the steps below will get you there properly.

    https://www.snbforums.com/threads/amtm-step-by-step-install-guide-l-ld.56237/
     
  10. Jack Yaz

    Jack Yaz Part of the Furniture

    Joined:
    Apr 20, 2017
    Messages:
    2,111
    L&LD likes this.
  11. claudiu911

    claudiu911 New Around Here

    Joined:
    Apr 23, 2019
    Messages:
    7
    L&LD likes this.
  12. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,111
    Thank you for the video.

    Try rebooting the router first. Leaving the USB plugged into it. I am guessing this is a timing/order issue. (Maybe amtm should not be running before plugging in the USB drive, or, the NTFS version that the MBP is implementing isn't, somehow, compatible.

    If rebooting the router does work, format the USB drive again as FAT.

    Insert it into the router and then startup amtm.

    If this still doesn't work? I would suggest an M&M config of your router, please see my signature below for the link to get it to a good/known state again.
     
    Billy Chaney likes this.
  13. Billy Chaney

    Billy Chaney Regular Contributor

    Joined:
    Mar 16, 2018
    Messages:
    109
    Location:
    Florida
    I had the same problem with a 2 or 3 year old Patriot USB drive. I finally used mini tool partition wizard to format it. When I finally got all my scripts loaded, a couple of days later it died on me. I don't know how old your drive is but maybe you need a new one.
     
    HuskyHerder, skeal and L&LD like this.
  14. claudiu911

    claudiu911 New Around Here

    Joined:
    Apr 23, 2019
    Messages:
    7
    Tbh it's not that new, but I tried multiple flash drives.
     
    Billy Chaney and L&LD like this.
  15. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,111
    Try the FAT format. That is native to the MBP. There may be a compatibility issue going on.
     
    Billy Chaney likes this.
  16. EmeraldDeer

    EmeraldDeer Senior Member

    Joined:
    Dec 22, 2017
    Messages:
    491
    Location:
    Massachusetts
    Does MacOS allow you to erase without reformatting?

    If not, then perhaps choose a filesystem which the router cannot mount. exFAT?
     
    Last edited: Apr 23, 2019
    Billy Chaney and L&LD like this.
  17. claudiu911

    claudiu911 New Around Here

    Joined:
    Apr 23, 2019
    Messages:
    7
    I already tried to format it as FAT, NTFS, ext4 I know sometimes OSX fucks with partitions... So, I tried to format the flash drive from a Linux VM... Unfortunately same outcome.
     
  18. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,111
    If borrowing a friends PC doesn't solve this, a full reset should. ;)
     
    Billy Chaney likes this.
  19. HuskyHerder

    HuskyHerder Senior Member

    Joined:
    May 12, 2017
    Messages:
    319

    I had the same problems with my RT-AC5300, and my USB formatting, from my MBP, I also tried formatting on a Mac mini. 2012, & 2014 model using macOS 10.13 & 10.14
    Multiple VM's, and Paragons EXTFS for Mac, all failed due to some issue. The only thing that worked was formatting from the router and I have never looked back. It's the only formatting option I trust. Admittedly I have not tried the AMTM formatting option yet...I have not had the need.
    https://www.snbforums.com/threads/ext4-disk-formatting-options-on-the-router.48302/

    I would also recommend purchasing a new drive, I went with a sandisk ultra flair. It does get very hot.

    I had tried a total of 4 USB drives I had lying around and they failed. They were the same mfg. hence my trying another brand.

    There is topic here in the forums with recommended types, and user experiences. My choice was mainly it being midnight and living across the street from Wally World.

    Good luck.
     
    Last edited: Apr 23, 2019
  20. HuskyHerder

    HuskyHerder Senior Member

    Joined:
    May 12, 2017
    Messages:
    319
    @claudiu911

    I have a post awaiting moderation, Not sure what I said, but I digress. When it gets posted, check it out about my experiences with formatting on my Macs and my 5300.