Cannot Apply Administration Configurations / Cannot Delete Network Place (Samba) User


New Around Here
Hello all. New user here.

I have an Asus RT-AC3100 running Merlin's 384.18. When I go to Administration | System and try to save changes there, clicking on the Apply button fails with "This account already exists. Please enter a different name." I read somewhere that this happens if on Network Place (Samba) the system user is not the first one on the list. I have checked and true, there is an old user name at the top of the list. I have tried deleting it, but the delete button is disabled for that user. How can I delete that user (which I no longer have a need for)? Can I ssh into the router and remove it via some config file? I have tried smbpasswd -x, smbpasswd -del, but the user gets added back to /etc/samba/smbpasswd every time the service restarts, and continues to stubbornly show at the top of the user list in USB Application | Network Place (Samba). Help!


Part of the Furniture
See @ColinTaylor post here:


Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!