What's new

Cannot come back from advanced tomato to asus merlin

tnkrer

Occasional Visitor
I switched from asus-merlin 380.66_4 to Advanced Tomato 3.4.140 AIO. When going from asus-merlin to tomato, I used mini CFE browser in rescue mode, then cleared nvram by doing WPS reset and everything worked fine. (This post explains why I did that)
Now that I have figured out my problem, I want to get back to asus-merlin. So I tried to reverse the process. I factory reset the router and then tried to upgrade using tomato's upgrade menu. I used RT-AC68U_380.66_4.trx file. However, very quickly it gave error message - /tmp/flashuvCf3t: Bad trx header and rebooted back to tomato.
I decided to try an earlier version of asus-merlin, so I tried RT-AC68U_378.56_0.trx I got same result. (And I had checked the sha256 for these files and they were correct)

I also tried using CFE mini browser in rescue mode and it uploaded the trx file (both versions) and finished processing without any visible errors, but when it was done, I was still on tomato, so I assume it actually failed.

What should I do to get back to asus-merlin? Or would I risk bricking the router? (There is at least one thread that has same error and a bricked router)

I am sure tomato is a fine firmware, I am just used to asus-merlin and it worked well for me
 

martinr

Part of the Furniture
Do you have anything plugged into the usb drive on the router? If so, unplug it and try again.

Could you also let us know, in the other thread, what the original problem was?

And don't forget that the factory default reset is done after flashing the new firmware.
 
Last edited:

tnkrer

Occasional Visitor
Nothing plugged into usb drive ..
In one of the threads about 378.56 release, someone reported the same problem and said that 378.55 worked and then he could upgrade using asus-merlin upgrader. So planning the do that. I found one 378.55 on the sourceforge mirror .. I hope that is the right one ..
 

det721

Very Senior Member
Its possible. Asus firmware now needs validation to install, now that you have another third party code other then Merlins it may have lost its validation and wont load. Just a thought.
 

john9527

Part of the Furniture
You need to load a firmware as a step update that defines a 64M rootfs, but still fits in a 32M space. 378.55 should work. If not, try ASUS OEM level 376.3636 if your AC68 is rev A1, A2 or B2.
 
Last edited:

Sablaky

New Around Here
I had installed Merlin and then Advanced Tomato 3.4.140 on a TMobile RT-68U router. I wanted to revert back to Merlin from Advanced Tomato but I could not. I tried everything like Firmware Restoration Tool, CFC, Telnet till I came across this link. As john9532 said I downloaded Merlin 378.55. I did factory reset on the router, let the router reboot. I pushed and hold the reset button and powered on the router. On the FF browser 192.168.1.1 to open the CFE browser, cleared the NVRAM. After that I flashed the Merlin. I did patiently wait for several minutes till the router rebooted by itself (don't click anything or click continue). When the router rebooted I got the Merlin interface. Thank you so much john9527.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top