What's new

Cannot install chrony on RT-N66W?

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Meshkoff

Occasional Visitor
Does anybody manage to install chrony on ASUS RT-N66 (374.43_43E6j9527) (Merlin LTS fork)?

I'm trying set up ntpMerlin to use chrony and getting this:

Bash:
dmitry@RT-N66W:/tmp# opkg install chrony
Unknown package 'chrony'.
Collected errors:
* opkg_install_cmd: Cannot install package chrony.
dmitry@RT-N66W:/tmp#

Then i manually download .ipk file and try to install offline:

Code:
dmitry@RT-N66W:/tmp# opkg install /tmp/chrony_4.1-2_mipsel-3.4.ipk
Unknown package 'chrony'.
Collected errors:
* pkg_hash_fetch_best_installation_candidate: Packages for chrony found, but incompatible with the architectures configured
* opkg_install_cmd: Cannot install package chrony.

No luck here, is it really architecture issue or maybe i just need to update firmware?
 
Last edited:
Most on here have probably installed it using NTPmerlin from within AMTM.
 
Does anybody manage to install chrony on ASUS RT-N66 (374.43_43E6j9527) (Merlin LTS fork)?

I'm trying set up ntpMerlin to use chrony and getting this:

Bash:
dmitry@RT-N66W:/tmp# opkg install chrony
Unknown package 'chrony'.
Collected errors:
 * opkg_install_cmd: Cannot install package chrony.
dmitry@RT-N66W:/tmp#

Then i manually download .ipk file and try to install offline:

Code:
dmitry@RT-N66W:/tmp# opkg install /tmp/chrony_4.1-2_mipsel-3.4.ipk
Unknown package 'chrony'.
Collected errors:
 * pkg_hash_fetch_best_installation_candidate: Packages for chrony found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package chrony.

No luck here, it is really architecture issue, maybe i need to update firmware?
Probably the entware repository doesn't have a supported chrony for that architecture, if that is the case there is not much you can do. If I recall correctly, they only have only a very limited ntp daemon for entware repository of that architecture setup.
 
That is a deprecated router with respect to Merlin software.
 
That is a deprecated router with respect to Merlin software.
I'm using Merlin LTS fork by John, as i mention in first post. This router still supports by this firmware and has updates, thanks to John.
I know it's old model, but it works fine and suit my needs, so i decide just keep it until router die.
 
I'm using Merlin LTS fork by John, as i mention in first post. This router still supports by this firmware and has updates, thanks to John.
I know it's old model, but it works fine and suit my needs, so i decide just keep it until router die.
Alot can be done with johns fork , the only short comings are limited entware (and by extension other developers) support for older architectures. As technology progresses, this will only become more bad news down the road.
 
Alot can be done with johns fork , the only short comings are limited entware (and by extension other developers) support for older architectures. As technology progresses, this will only become more bad news down the road.

That's true, i have RT-AX56U in second house and it just awesome)
 
Me too, but result are identically same

There's supposed to be a menu item to use a more up to date Entware repo (unmaintaned for a long time but still has more recent versions of packages) under either amtm or Diversion for MIPS routers. Did you try after switching to that repo by any chance?

I no longer have my RT-N66W so I can't check where to enable that repo or the URL of it, sorry.

NVM, found it: https://www.snbforums.com/threads/mips-entware-backports-repo-entware-ng-reloaded.49468/#post-439207
 
There's supposed to be a menu item to use a more up to date Entware repo (unmaintaned for a long time but still has more recent versions of packages) under either amtm or Diversion for MIPS routers. Did you try after switching to that repo by any chance?
That option is in Diversion only (Parallel use Entware-backports Repo). https://maurerr.github.io/ lists package collectd-mod-chrony 5.9.0-6, while pkg.entware.net lists:
chrony 4.1-2
chrony-nts 4.1-2
collectd-mod-chrony 5.12.0-15

In other words, this post may not help OP.
 
Thanks for tips, installing collectd-mod-chrony from https://maurerr.github.io/ and choosing chrony in ntpmerlin settings results this constantly repeating messages in log:

Code:
Feb 19 12:31:39 timeserverd: chronyd restarted
Feb 19 12:31:44 timeserverd: chronyd dead, restarting...

I assume there is no workaround here
 

Latest threads

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!

Members online

Top