1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Cannot save settings on RT-AC86U

Discussion in 'Asuswrt-Merlin' started by Blackhawk, Jan 12, 2019.

  1. Blackhawk

    Blackhawk New Around Here

    Joined:
    Jan 12, 2019
    Messages:
    2
    My router was rebooting constantly. I sent it back to ASUS and I started configuring the replacement unit today.

    I do have strange behavior. I can not save any changes. I can navigate through the pages, but whenever I hit Apply, nothing happens. I cannot change language either. I managed to setup WAN and Wifi through the Internet setup.

    I decided to flash the router with AsusWRT-Merlin 384.8_2 through recovery mode (as nothing happens when I select the file through the manual firmware update page). However I have the exact same problem.

    Am I overlooking anything? Trying to avoid going through another painful RMA process.

    EDIT: Tried to factory reset. Neither the Restore nor the Initialize button seems to work. It brings up the warning window, but then nothings happen when I it OK.
     
    Last edited: Jan 12, 2019
  2. Jack Yaz

    Jack Yaz Part of the Furniture

    Joined:
    Apr 20, 2017
    Messages:
    2,197
    Which browser? Any extensions/plugins such as an Adblocker/NoScript?

    Do any errors come up in the Developer Tools (F12) Console when you click?
     
  3. Blackhawk

    Blackhawk New Around Here

    Joined:
    Jan 12, 2019
    Messages:
    2
    I solved the issue. It seems to be PC related. Swapped to laptop and iPad, both working.
     
  4. RMerlin

    RMerlin Super Moderator

    Joined:
    Apr 14, 2012
    Messages:
    30,478
    Location:
    Canada
    This is generally caused by a browser add-on.
     
    Jack Yaz likes this.