Cannot SSH into router when connected via 5Ghz wireless connection

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

ADarkDividedGem

New Around Here
I am using the RT-AC66U B1 with firmware version 386.1_2

I have enabled SSH via port 22 in the system settings
FireShot Capture 018 - ASUS Wireless Router RT-AC66U B1 - System - router.1nwp.co.uk.png


When I am connected via the 2Ghz wireless (not guest) connection I have no problems logging into the router over SSH using PuTTY:

connected.png


When I try the same thing using the 5Ghz wireless connection PuTTY simply times out
notconnected.png


In the system log it simply lists the attempt and that the connection timed out:
Feb 16 13:13:18 dropbear[25274]: Child connection from 192.168.0.22:56297
Feb 16 13:13:39 dropbear[25274]: Exit before auth from <192.168.0.22:56297>: Error reading: Connection timed out
Does anyone know what I could be doing wrong or should I open up a bug on the asuswrt-merlin.ng GitHub page?
 

Jeffrey Young

Senior Member
Just a guess, but due you have Set AP isolated turned on in the professional tab? I don't have the 66, so I am more brain storming here.
 

ADarkDividedGem

New Around Here
Thanks for the suggestion but I have never touched the professional tab so everything is currently set to their defaults which means "Set AP Isolated" is set to "No" for both 2.4Ghz and 5Ghz bands.
I made a note not to try this when connected to my two Guest Wireless networks (2.4Ghz and 5Ghz) since the "Access Intranet" is set to "Disabled" preventing them from gaining access to the router over SSH. So I can confirm I am connected over my main non guest wireless network.
 
Last edited:

eibgrad

Very Senior Member
And there's nothing else odd about 5GHz? You can access internet, other LAN devices, the GUI, etc., all normally? Because it is strange given the LAN ports and wireless radios are typically all assigned to the same default bridge (br0), and thus seen and treated as one and the same. If there was something wrong w/ this setup, I would suspect other things besides just ssh are also not correct.
 

ADarkDividedGem

New Around Here
There are no other difference I can see between the two bands. Both access the internet, both access other LAN devices over SSH and both access the web GUI.

Out of curiosity I thought I would try simply setting "Set AP Isolated" to "Yes" on the 5Ghz band and then back again to see if reapplying the settings would change anything. As soon as I reconnected to the 5Ghz wireless connection with "Set AP Isolated" to "Yes" I was able to SSH into the router no problem. Then I set it back to "No" again and I could still gain access to the router.

Maybe some of the default settings didn't get applied correctly and simply hitting Apply was enough to reset the 5Ghz wireless connection back to it's default state. Not really sure what to do with this information as I am not sure if it can be replicated to be reported as a bug but I am just glad it seems to be solved at my end.
 

Jeffrey Young

Senior Member
Was this a dirty upgrade to current version? It's amazing the problems that can just "go away" with a clean start.

Glad you got things sorted out.
 

ADarkDividedGem

New Around Here
My upgrade to the latest firmware was dirty but I have had this issue for a while. In a previous firmware version I had done a factory reset so I could document all the settings I was changing and it was then that I had noticed trouble connecting to the router on the 5Ghz band.
 

andresmorago

Senior Member
Hello.
Im bringing up this topic as i having exactly the same sympton on a AC68u. I upgraded to latest 386.2 and have done @L&LD 's nuclear reset twice. SSH wont work if i am in the 5GHz network.
Code:
Apr  3 08:33:46 bga01 dropbear[8184]: Exit before auth from <10.0.4.31:1787>: Error reading: Connection timed out
 

peraburek

Senior Member
I would like to report the same problem

SSH not responsive on 5GHz wireless, even after two factory resets, Asus Merlin Firmware Version: 386.2 running @ Asus RT-AC68U
 

MvW

Senior Member
I just used a mobile SSH client (Shelly) on my iPhone, connected to 5Ghz and can connect without issues to my router through SSH.

To double check I connected an external USB 3.0 RTL8812AU dual band wifi dongle to my laptop (I don't have 5 Ghz available on my internal wireless network card), connected to the 5Ghz network and connected without any problems, using Putty, to my router.

I don't think you problem lies in 5Ghz band, but the question is: what causes it then?

Have you enabled SSH access or has it accidentally been disabled?
 

peraburek

Senior Member
You can connect to SSH, I didn't said it doesn't work at all, it is slow and not responsive (delays when tying commands)

after some time SSH stops working, here and there you can still make connection, however typing simple

ping 1.1.1.1

command takes 2 minutes, you are disconnected a few times etc.


In order to isolate the issue, I have tried MobaXterm instead of Putty, there is no difference

I will test the same with 2.4GHz and I will let you know
 

MvW

Senior Member
You can connect to SSH, I didn't said it doesn't work at all, it is slow and not responsive (delays when tying commands)

after some time SSH stops working, here and there you can still make connection, however typing simple

ping 1.1.1.1

command takes 2 minutes, you are disconnected a few times etc.

I misunderstood you, my apologies. I thought you weren't able to connect at all.
As far slowness, I can't reproduce this either. I honestly think you need to look for the cause elsewhere, as I don't see how SSH could perform worse on either one of the available bands.


Best regards,
Marco
 

ColinTaylor

Part of the Furniture
I misunderstood you, my apologies. I thought you weren't able to connect at all.
Yes that was my understanding as well. He said he had "the same problem". The problem being discussed is "Cannot SSH into router when connected via 5Ghz wireless connection". Nobody mentioned anything about slowness.
 

peraburek

Senior Member
SSH works fine on 2.4GHz, and it works fine from mobile device on 5GHz (Android)
it may be issue with Intel Wireless card (Win 10) and Asus router only at 5GHz, still strange, looking for root-cause
 

peraburek

Senior Member
how can I add this to SSH config ?

Code:
IPQoS cs0 cs0

maybe it would help
ruled out my freeze/disconnection SSH problems :slight_smile:

Edit: explaination of the problem:
OpenSSH sets the TOS (type Of Service) field in the IP datagram as “lowdelay” for interactive sessions and “throughput” for non-interactive sessions. My router doesn’t handle properly those settings, so I changed them in Cs0, Cs0 (aka 0x00, 0x00) <==> (best effort, best effort) and solved the instability/freeze SSH issues.

https://discourse.osmc.tv/t/solved-ssh-connection-sometimes-hangs/76504/5
https://github.com/guysoft/OctoPi/issues/294
https://manpages.debian.org/stretch/openssh-server/sshd_config.5.en.html#IPQoS
 

peraburek

Senior Member
OK, it is some compatibility issue between Windows 10 and Asus SSH (dropbear) only on 5GHz
when I try to access SSH from CentOS (Linux) running as VM in Windows 10, it works, and it doesn't have instability/freeze SSH issues
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top