Cannot upgrade firmware AX11000 - WRT-Merlin


New Around Here
About a month ago I replaced the stock firmware with Merlin 386_3_2 which works fine.
Today I wanted to upgrade it to 386_4 which is suggested.

But as soon as I visit the upgrade page (used chrome, firefox, edge on PC and Chrome on Pixel 6) a glass pane pops up "Downloading firmware" and that seems to stay that way.
I also cleared all browser cache / temp files, but still no go.
This makes it impossible for me to upgrade the router (with the firmware I had already manually downloaded).

Any tips / suggestions on how to fix this?


Jeffrey Young

Very Senior Member
Unmount and remove any USB drives first, disable all user scripts, and reboot the router first. If that fails, you can try the recover utility.


New Around Here
I have no USB drives mounted, no user scripts running.
Just found a workaround though.... Pressing F5 to reload the page seems to have worked... updating firmware as we speak.
thanks for your fast reply.

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!