Can't access web gui or hard drive attached to AC86U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

JumboJoe

New Around Here
I am attempting to setup a vpn server on my router so that I can remotely access my external hard drive that is attached to my router. I don't want to open up my hard drive to the entire internet so I updated to the merlin firmware so that I can disable the wan access. I first attempted the latest stable version of the firmware but then I was unable to login to my router. I then tried the most recent beta version and that's what is currently installed.
My internet still works fine but I cannot access my hard drive at all anymore and I'm having issues logging in to my router. When my hard drive is not connected, I can login to the router just fine without any problems. I noticed that my cpu usage was pretty much non existent and that my memory usage was around 55-60%. When the hard drive is connected, if I reboot the router I am able to login but only for a couple of minutes before it freezes and I lose access. I notice that when the hard drive is connected both cpus are pretty much under a full load, they basically alternate, one reads 100% and the other is basically at 0% but then they keep switching back and forth until the gui freezes. I also noticed that the memory only shows around 25MB available.

I've read several posts about not being able to login and if it's ok to be using so much of the resources but where my problem is unique is that I have a hard drive attached to my router that I can no longer access.

Is this router simply not up to the task of what I'm trying to do or is it likely there is something else that is causing my problems.


I appreciate any advice or suggestions, thank you
 

ColinTaylor

Part of the Furniture
What exact firmware versions have you tried? "Latest" and "recent" aren't helpful. What firmware version were you using before installing Merlin?

When moving from a 384.x firmware to a 386.x firmware there is a one-time database update that can take several hours during which the router will be slow or non-responsive.

High CPU usage after bootup is normal if you have an attached hard drive and have the Media Server enabled. Turn it off under USB Application > Servers Center > Media Server.

When you say you "cannot access my hard drive at all anymore and I'm having issues logging in to my router" give specific details. What exactly are you doing and what is the response.
 

JumboJoe

New Around Here
The first firmware I tried was 386.2_6
The current firmware I have is 386.3_beta3
I'm not sure what version I was using before the Merlin upgrade. I last updated my firmware maybe 1-2 months ago if that helps at all?

I read about the database updated that can take several hours but I don't think that's the problem as I upgraded to the Merlin firmware about a week ago, just been too busy to try to troubleshoot.

The high CPU usage continues until the page freezes, it doesn't ever stabilize. I would estimate the gui is active for only about 1-2 minutes before it freezes.

The error I get when trying to login to gui is:

Unable to connect
Firefox can’t establish a connection to the server at 192.168.50.1

If I reboot the router I'll be able to login again. I tried 192.168.1.1 and router.asus.com as well, but they all get the same error.

My hard drive no longer shows up in my file explorer and I don't have access to any of the files, I get the following error message:

Connecting to "smb://WORKGROUP;[email protected]/-pictures/" failed
Failed to mount Windows share: No such file or directory
 

L&LD

Part of the Furniture
Why are you using Beta 3? Use the 386.3_0 final release firmware instead.
 

JumboJoe

New Around Here
I tried the Beta 3 because the 386.2_6 didn't work. Haven't had a lot of time to try getting this working again. I will change to 386.3_0 right now
 

ColinTaylor

Part of the Furniture
It sounds like your router (or perhaps just the GUI) is in a reboot or crash loop. It's also possible that if you had previously enabled access from the WAN that some malware may have corrupted your configuration.

Either way, at this point I suggest you do a factory reset and configure your router manually. It'll probably save you time in the long run.
 
Last edited:

Crimliar

Occasional Visitor
Just one thing to add to what has already been asked: Are you trying to use a USB powered Hard Drive, since these can cause problems! A USB Hard Drive with its own power should be fine though!
 

kernol

Very Senior Member
First thing I would do is test the external drive by connecting it directly to your workstation. If it is formatted as ext? there are plenty of free utilities to be able to access it from Windows10 PC. Make sure it is error free. If not - there's your problem - faulty drive!
 

JumboJoe

New Around Here
I turned off the media server and my memory and cpu usage is similar to what it was when the hard drive was not turned on. I've been logged into the gui for a good 10+ minutes now and it hasn't froze on me yet so that's a promising sign. I still can't access the files on the hard drive but that's what I'm going to try to troubleshoot now for the next little while.

WAN access was never enabled so I'm doubtful that is it. I will try a factory reset when I have time if I can't get it working, probably won't get to it until next week sometime.

My hard drive has it's own power source so no, I am not trying to use a USB powered hard drive.

Yes, the hard drive is formatted as ext. I am using Linux Mint, not windows so I could easily just plug the hard drive into my laptop. It was a brand new hard drive when I hooked it up maybe two to three months ago, I can check it for errors next week as well. I could be wrong but I don't think there will be any errors. In the gui there is a "health scanner" for the hard drive, I ran the test but it doesn't show any results
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top