Can't configure IPv6 on RT-N66U

Arsonist

New Around Here
I cannot seem figure out how to make it work or make it work correctly. I've been digging through the forums and found some tips that helped me, but it doesn't seem to work like it should. Maybe I'm missing something in my configuration.

Recently I've been using 374.43_44E5j9527, but upgraded to 374.43_52E7j9527.

If I set "Prefix delegation requires address request" to "Yes" and "nvram set ipv6_isp_opt=1" (documentation) then I can pass IPv6 tests from my PC, but in the "IPv6" tab of System Log menu "WAN IPv6 Address" is empty and "WAN IPv6 Gateway" has this ": :" in the IP field. I don't think it's a normal behavior.

IP address that the test sites show is located in "IPv6 LAN Devices List". IPv6 also appears to be dynamic despite my ISP claiming that it should be static.

xnview_DkreGquJwS.png


xnview_ZW1d5eiHi1.png

ISP recommends:

WAN:
PPPoE Dual Stack
DHCPv6 PD
IPv6 Gateway: SLAAC
Receive IPv6 DNS automatically

LAN:
DHCP PD
Stateless

They also offer settings for Mikrotik. Since I can only attach 5 files I uploaded them on my Google Drive: https://drive.google.com/file/d/1uBzRl7b9GlH_8bCkw-21cgviz8_uglQS/

These are my initial settings.

firefox_rZj2Uwum74.png

I've also uploaded two logs (I cannot seem to attach them) after setting "nvram set ipv6_debug=1". One with IPv6 initial settings and the other is with "Prefix delegation requires address request = Yes" and "nvram set ipv6_isp_opt=1".

 

heysoundude

Part of the Furniture
Have you tried enabling "Prefix delegation requires address request" at the bottom of the IPv6 GUI page? Save and reboot...
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top