1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

can't get dnsmasq to work

Discussion in 'ASUS AC Routers & Adapters' started by Ojee, Feb 18, 2020.

  1. Ojee

    Ojee Occasional Visitor

    Joined:
    Dec 2, 2017
    Messages:
    31
    I'm using a Synology NAS to listen to music when I'm at work. To access it, I have DDNS running on my Asus RT-AC87U, along the lines of xxxx.asuscomm.com:1234. When I come home, my phone switches to wireless, and that's where the trouble starts. In order to keep listening, I have to log out and relogin using the internal IP of my NAS. This is a chore, and I have to do this every time I enter or leave my house. I wish this worked as seamlessly as spotify for instance.

    The problem is that I can't access the external asuscomm address from inside the network. It will only access the internal IP address. I've done some digging and apparently this is a dnsmasq problem (I could be wrong), but for the life of me I don't know how to fix it. There doesn't seem to be an option on the router to force the asuscomm address to the correct IP when I'm behind my router.
     
  2. Val D.

    Val D. Very Senior Member

    Joined:
    Jun 16, 2019
    Messages:
    1,406
    What you need is called Hairpinning, NAT loopback, NAT reflection... but wait for ASUS wizards here to tell you what you need to do.