Change Locale Settings

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

bl4d300

New Around Here
I live in Brazil but I bought my router in the USA.

I want to know if it's possible to change the locale settings from the router to allow me to choose the 11+ channels and to use higher TX power on the radios.
 

Gingernut

Senior Member
You can use these commands through telnet if on original firmware or on the cmd page if on RMerlin's.

nvram set pci/1/1/ccode=EU
nvram set pci/2/1/ccode=EU
nvram set wl0_country_code=EU
nvram set wl1_country_code=EU
nvram set regulation_domain=EU
nvram set regulation_domain_5G=EU
nvram commit
reboot

To change back to the US just change all the EU for US.

This would change your wireless regulatory domain to Europe on both radios which has more 2.4GHz channels, less 5GHz channels and also lower TX power output than the US.

Take care
 

Stimpy

Occasional Visitor
Thank you very much for the information Gingernut!

Do you know if the maximum TX output for the 5GHz band is supposed to be 200mW?

I thought that it was supposed to be 500mW, but the GUI says 200 is the max, and will not let me set higher.
 

RMerlin

Asuswrt-Merlin dev
5 GHz output power limitation rules are... complicated. Max allowed power vary depending on which channel you are using. The old "500 mW for every channel" rule was dropped by Asus, as they now properly implement power control according to the channel used.
 

Stimpy

Occasional Visitor
You can say that again Merlin, the power rules are just totally crazy, and mostly unjustified at the power levels we are talking about here.

I have gone through every single available channel on the 5GHz band, and the output (in the GUI) does not go above 200mW.

I am pretty sure that the high (149+) channels are supposed to be at 500mW, and the low (64 and lower) channels 200mW. Looks like another bug, either in the GUI or the artificial limits ASUS are imposing. Or maybe I have the limits the wrong way round?

Merlin, do you know what firmware version had the old power limits still in effect?
 

nemesis

New Around Here
Can't get 5Ghz SSiD to show on ASUS AC68u Merlin 376.47

Hi,
I've been a long time Tomato user but recently bought 2 AC68U for home so figured I'd try Merlin since I bought them for their performance rather than the extra features Tomato gives.
Generally I think they are one of the best performing routers I have ever used.

My issue is my Surface Pro 2 will not see the 5Ghz SSID.

I can see and connect to it via Iphone, Ipad etc, just not the Surface..

I think I've determined its an Asus issue (rather than specifically the Merlin firmware) because:
1x AC68U running Merlin
1x AC68U running stock firmware

Both will not let the surface pick up the 5Ghz (as mentioned, it will not even show in the list of available networks)

In addition I have 2 x Linksys E3000 that I used before I had the Asus.
1x E3000 running Tomato by Shibbly
1x E3000 running default stock firmware
Both of the E3000 broadcast the 5Ghz SSID and can be picked up and connect fine to the Surface Pro 2 (thus eliminating the Surface from the issue?)

On the Asus I've played around with the settings and have the 2.4 on 20Mhz and the 5 on 80Mhz

One the E3000 I have the option to set the region. I've never changed this but it is set on 'CANADA' (don't ask me why!)

I'm guessing I need to change the locale of the Asus to give me more channels however I don't see an option to do this.

I do want to use the 5Ghz on the Asus with my Surface as I have a lot of other stuff connected to the 2.4 and I know I can get cleaner and faster speeds with it.

I haven't tried Tomato on the Asus to see if it makes a difference and don't really want to go down that route at the minute.

Any suggestions would be appreciated.
 

redpants

Regular Contributor
You can use these commands through telnet if on original firmware or on the cmd page if on RMerlin's.

nvram set pci/1/1/ccode=EU
nvram set pci/2/1/ccode=EU
nvram set wl0_country_code=EU
nvram set wl1_country_code=EU
nvram set regulation_domain=EU
nvram set regulation_domain_5G=EU
nvram commit
reboot

To change back to the US just change all the EU for US.

This would change your wireless regulatory domain to Europe on both radios which has more 2.4GHz channels, less 5GHz channels and also lower TX power output than the US.

Take care

Bump!

This still isnt working. Used to work fine on older merlin fw but not anymore. :(
 

mavack

Guest
I am finding similar issues.

nvram set wl0_country_code=AU
nvram set wl1_country_code=AU
nvram set pci/1/1/ccode=AU
nvram set pci/2/1/ccode=AU
nvram set wl_country_code=AU
nvram set regulation_domain=AU
nvram set regulation_domain_5G=AU
nvram commit
reboot

or
wl country AU
reboot


However after the reboot it changes back to US and the channels are still not available.

RT-AC66u firmware 376.49_4

I'm not sure if it has ever worked honestly as i was just looking into it from another post on whirlpool and thought i should correct mine.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top