Changing 5ghz channel for AI Mesh Node?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Kashif Tasneem

Regular Contributor
Hi. My main router is tri-band AX-11000 and node is AX-55. AX-11000 is on Merlin 386.3_2 while node is on stock 3.0.0.4.386_45898-gfa90458.

Both are connected via Ethernet, so, all wifi bands are free.

Main router's 5 Ghz-1 is set to channel 48 while 5Ghz-2 is set to channel 149.

My node's 5Ghz channel is always 48. I want it to be on 149 because some of my devices only support channels 149 to 161.

How can I do that?
 

CaptnDanLKW

Regular Contributor
The 386.2_x code is based on GPL 42095 which has this issue. There is fix in later GPL versions for this exact issue (Mesh code not copying over all the settings, including fixed channel #) but due to Issues on Asus's side with, there hasn't been any source code released for a while. That means RMerlin has not had anything to work with in a while for a new release.

You could try to ssh over to the node, set the wl_ nvram variable and restart wireless on that node. I think that will stay set unless the main node is rebooted (in which it will reestablish the mesh node connection, and overwrite the value). You'll have to test. YMMV.
 

Morris

Senior Member
have you tried changing the AX-11000 5Ghz-1 to 149 and 5Ghz-2 to 48? This is just a guess

Morris
 

LimJK

Very Senior Member
Only lower channels show up in 5Ghz-1 and higher channels in 5Ghz-2. So, this is not possible.
Kashif,
Have you tried to switch AiMesh to "Ethernet Backhaul Mode"? I think it should release both 5GHz-1 and 5GHz-2 for your devices. (Disclaimer: I have not tried it myself, I have given my Triband Router to my daughter's family.)

Screenshot 2021-10-10 at 16.08.28.png
 

Morris

Senior Member
Only lower channels show up in 5Ghz-1 and higher channels in 5Ghz-2. So, this is not possible.

How about if you set both to auto and then try that?
 

LimJK

Very Senior Member
Thanks but I am already on Ethernet Backhaul Mode.
If you have Turn ON Ethernet Backhaul Mode explicitly, Both 5GHz-1 and 5GHz-2 should be visible (ie. not hidden) on Main AiMesh Router. May be you can try Turning Off 5GHz-1 Band on Main AiMesh Router to see if that might influence you AiMesh Node to use higher 5GHz-2 Band. Just an idea. I do not have Triband router at home to test it. Hope you find your solution.
 

Kashif Tasneem

Regular Contributor
If you have Turn ON Ethernet Backhaul Mode explicitly, Both 5GHz-1 and 5GHz-2 should be visible (ie. not hidden) on Main AiMesh Router. May be you can try Turning Off 5GHz-1 Band on Main AiMesh Router to see if that might influence you AiMesh Node to use higher 5GHz-2 Band. Just an idea. I do not have Triband router at home to test it. Hope you find your solution.

Thanks. I will try this.
 

Kashif Tasneem

Regular Contributor
If you have Turn ON Ethernet Backhaul Mode explicitly, Both 5GHz-1 and 5GHz-2 should be visible (ie. not hidden) on Main AiMesh Router. May be you can try Turning Off 5GHz-1 Band on Main AiMesh Router to see if that might influence you AiMesh Node to use higher 5GHz-2 Band. Just an idea. I do not have Triband router at home to test it. Hope you find your solution.

I switched off 5Ghz-1 band (which was using channel 48) on main router but still node is broadcasting on channel 48.
 

LimJK

Very Senior Member
I switched off 5Ghz-1 band (which was using channel 48) on main router but still node is broadcasting on channel 48.
Kashif,
Sorry, looks like that does not help :( for a Triband AiMesh Router. On my DualBand AiMesh Router (RT-AX88U) When I set my 5GHz to Low or High Band, both my AiMesh Nodes (RT-AC86U) the 5GHz band will follow the AiMesh Router.

Long time ago I used to have RT-AC5300 Triband Router, at that point AiMesh 1.0 setup forced one band to be hidden and only one band can be used by my Wifi devices. It was at that point I decided the junk the Triband and move to Dualband RT-AX88U and have been very happy with my configuration:)
 

Kashif Tasneem

Regular Contributor
Kashif,
Sorry, looks like that does not help :( for a Triband AiMesh Router. On my DualBand AiMesh Router (RT-AX88U) When I set my 5GHz to Low or High Band, both my AiMesh Nodes (RT-AC86U) the 5GHz band will follow the AiMesh Router.

Long time ago I used to have RT-AC5300 Triband Router, at that point AiMesh 1.0 setup forced one band to be hidden and only one band can be used by my Wifi devices. It was at that point I decided the junk the Triband and move to Dualband RT-AX88U and have been very happy with my configuration:)

Thanks for the suggestions :)
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!

Members online

Top