Changing DNS -> No more Web GUI *DNS_PROBE_FINISHED_NXDOMAIN*

Daarke01

New Around Here
I bought RT-AX56U upgraded to Merlin 365_2 (and later downgraded to 365 in case problem was due to newest firmware).

It's a huge problem. Whenever I change the DNS in lan->dhcp server-> Enter DNS:
Advertise router's IP in addition to user-specified DNS: No

I loose access to the Web GUI (router.asus.com). It only happens after the change, or if it somehow crashes after 100% completed when pressing apply.

DNS_PROBE_FINISHED_NXDOMAIN

Is there a solution to this? Or simply a firmware bug?
 
Last edited:

ColinTaylor

Part of the Furniture
Whenever I change the DNS in LAN -> DNS Servers, i loose access to the Web GUI (router.asus.com).
"router.asus.com" is a local DNS name for your router's IP address. If you change the DNS server to go directly to 8.8.8.8 Google's DNS server doesn't know what that domain is. This is intentional.

Is there a solution to this? Or simple a firmware bug?
It's not a bug. You have chosen to bypass your router's DNS server which is the only thing that knows about "router.asus.com". Therefore you will now need to use the router's IP address instead, e.g. 192.168.50.1.
 
Last edited:

Daarke01

New Around Here
"router.asus.com" is a local DNS name for your router's IP address. If you change the DNS server to go directly to 8.8.8.8 Google DNS server doesn't know what that domain is. This is intentional.


It's not a bug. You have chosen to bypass your router's DNS server which is the only thing that knows about "router.asus.com". Therefore you will now need to use the router's IP address instead, e.g. 192.168.50.1.
You know what. That fixed it. Im able to access through 192.168.50.1
I am not used to this with other routers since the usual way often works afterwards.
Thanks!
 

ColinTaylor

Part of the Furniture
Setting external DNS servers in the DHCP settings is usually a bad idea. You loose the speed benefits of a local cache and you loose the ability to resolve local host names.
 

Daarke01

New Around Here
Setting external DNS servers in the DHCP settings is usually a bad idea. You loose the speed benefits of a local cache and you loose the ability to resolve local host names.
I had to setup the DNS for my VPN service, that was the only reason for the change in settings.
But I'm returning the AX56U tomorrow. OpenVPN Speed limit was 50 Mpbs on a nearby server. I had hoped for more on a 1.5GHz core. Unless Wireguard support isn't released in the nearby future.
 
Last edited:

ColinTaylor

Part of the Furniture
I had to setup the DNS for my VPN service, that was the only reason for the change in settings.
For future reference in case you need to do this again, the usual way to change the VPN DNS servers is by using the Accept DNS Configuration option the VPN client settings.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top