Channel Options Now Available with Smart Connect (since 384.18)

JDB

Very Senior Member
So I updated my router(AC86U)/nodes(AC88U, 2x AC5300U) to 384.18 this weekend and found the new GPL's this is based on now allow setting fixed channel and bandwidth even with Smart Connect enabled - HALLELUJAH!

I should say I skipped 384.17 so please let me know if it was introduced then and I'll update my comments.

See new options in screenshot;
Screenshot 2020-07-05 at 10.33.11.png



There is an additional quirk relating to AiMesh and DWB I have found with using these setting which I want to stay, though I fear Asus will treat it as a bug and mess up my new found stability in some way.

Normally, as my 5300's are tri-band, the 86U and 88U connect to the hidden DWB channel on 5Ghz-2 (which is entirely pointless as I use ethernet backhaul, but that's a whole other pile of %*#@ that ASUS are still yet to fix!).
So prior to this f/w I ended up with client usable BSSID's on 2 different 5Ghz channels, 2 low end channels from the 5300's 5Ghz-1 and 2 high end channels from the 86/88U (the DWB always uses the high end of the spectrum). This isn't a big issue but would be nicer if it was all uniform (as it is as of this f/w...).

By setting the 5Ghz channel explicitly, the 86U and 88U now connect to the 5300's on the 'fronthaul' 5Ghz-1 channel. So the DWB channel is now just sat there only being connected between the 2x 5300's, not a problem for me, but would be dumb if you actually used wireless backhaul. You would be forced to use Auto channel selection to make DWB work (this is mildly annoying be an OK compromise for now IMO).

The reason I don't want them to mess with it, is, if my router is in Auto channel it seems to home in on ch36, which must have some kind of interference as it always goes down to 20Mhz (meaning my throughput is tiny and never gets close to my 350Mbps WAN speed). Any other channel and it uses 80Mhz. I've no idea why ch36 is broken, I'm in a detached house, on the edge of a field. I can detect my nearest neighbour's Wifi in a scan, but only occasionally at -90 RSSI and they are not using ch36 (usually 44 or higher). So I'm assuming there is a RADAR station or something that's creeping into the bottom of the wifi frequency range.

I still have no control over the DWB channel, but as above I don't care about that (other than the potential ability to completely remove DWB and re integrate the 5Ghz-2 back into Smart Connect which is currently impossible!). My concern is they will change it to maybe ignore this new setting when in a dual/tri band setup like mine and allow the 5Ghz-1 to go back to Auto (ideally the chosen channel should be passed onto the tri-band 5Ghz-1 even if the main router is going to ignore the setting and connect to DWB 5Ghz-2).

The full and proper solution IMO is to add 5Ghz-2 control to the main router (even though it is dual-band) because it is master over a tri-band device, and while they are at it add an option to properly disable DWB and have the same SSID across all radios (not the half cocked solution only currently available via the Asus Mobile App and even then only if the tri-band router is your main device, not a node), this way I could have my proper tri-band setup back again, no DWB and ethernet backhaul.

Anyway, I know lots of you have been interested in both Smart Connect options and AiMesh DWB so something new to chew on!
 

OzarkEdge

Part of the Furniture
So I updated my router(AC86U)/nodes(AC88U, 2x AC5300U) to 384.18 this weekend and found the new GPL's this is based on now allow setting fixed channel and bandwidth even with Smart Connect enabled - HALLELUJAH!

I should say I skipped 384.17 so please let me know if it was introduced then and I'll update my comments.
Asuswrt 81792 introduced fixed channels with Smart Connect... that should indicate when Asuswrt-Merlin got it.

OE
 

JDB

Very Senior Member
Asuswrt 81792 introduced fixed channels with Smart Connect... that should indicate when Asuswrt-Merlin got it.

OE
384.17 release notes mention 81790
384.18 mention much newer

So still not sure if it was introduced in .17 or .18


Sent from my iPhone using Tapatalk
 

OzarkEdge

Part of the Furniture
384.17 release notes mention 81790
384.18 mention much newer

So still not sure if it was introduced in .17 or .18
I don't think Asuswrt 81790 was published(?). 81792 was published and then pulled for unknown reason.

OE
 

swejuggalo

Regular Contributor
So I updated my router(AC86U)/nodes(AC88U, 2x AC5300U) to 384.18 this weekend and found the new GPL's this is based on now allow setting fixed channel and bandwidth even with Smart Connect enabled - HALLELUJAH!

I should say I skipped 384.17 so please let me know if it was introduced then and I'll update my comments.

See new options in screenshot;
View attachment 24535


There is an additional quirk relating to AiMesh and DWB I have found with using these setting which I want to stay, though I fear Asus will treat it as a bug and mess up my new found stability in some way.

Normally, as my 5300's are tri-band, the 86U and 88U connect to the hidden DWB channel on 5Ghz-2 (which is entirely pointless as I use ethernet backhaul, but that's a whole other pile of %*#@ that ASUS are still yet to fix!).
So prior to this f/w I ended up with client usable BSSID's on 2 different 5Ghz channels, 2 low end channels from the 5300's 5Ghz-1 and 2 high end channels from the 86/88U (the DWB always uses the high end of the spectrum). This isn't a big issue but would be nicer if it was all uniform (as it is as of this f/w...).

By setting the 5Ghz channel explicitly, the 86U and 88U now connect to the 5300's on the 'fronthaul' 5Ghz-1 channel. So the DWB channel is now just sat there only being connected between the 2x 5300's, not a problem for me, but would be dumb if you actually used wireless backhaul. You would be forced to use Auto channel selection to make DWB work (this is mildly annoying be an OK compromise for now IMO).

The reason I don't want them to mess with it, is, if my router is in Auto channel it seems to home in on ch36, which must have some kind of interference as it always goes down to 20Mhz (meaning my throughput is tiny and never gets close to my 350Mbps WAN speed). Any other channel and it uses 80Mhz. I've no idea why ch36 is broken, I'm in a detached house, on the edge of a field. I can detect my nearest neighbour's Wifi in a scan, but only occasionally at -90 RSSI and they are not using ch36 (usually 44 or higher). So I'm assuming there is a RADAR station or something that's creeping into the bottom of the wifi frequency range.

I still have no control over the DWB channel, but as above I don't care about that (other than the potential ability to completely remove DWB and re integrate the 5Ghz-2 back into Smart Connect which is currently impossible!). My concern is they will change it to maybe ignore this new setting when in a dual/tri band setup like mine and allow the 5Ghz-1 to go back to Auto (ideally the chosen channel should be passed onto the tri-band 5Ghz-1 even if the main router is going to ignore the setting and connect to DWB 5Ghz-2).

The full and proper solution IMO is to add 5Ghz-2 control to the main router (even though it is dual-band) because it is master over a tri-band device, and while they are at it add an option to properly disable DWB and have the same SSID across all radios (not the half cocked solution only currently available via the Asus Mobile App and even then only if the tri-band router is your main device, not a node), this way I could have my proper tri-band setup back again, no DWB and ethernet backhaul.

Anyway, I know lots of you have been interested in both Smart Connect options and AiMesh DWB so something new to chew on!
I've used Smart Connect on my AX88 with Auto channel for a long time. In the early firmware I had to use manual channels to get full speed on WiFi. Then it worked just fine until .16 (I think it was) where it reverted to the same slow connection. Yet again being forced to use manual channels. And this is just a single router. Same channel in both Auto and Manual. Everything identical. Just not using Auto channel. 286 (or something) vs 1200, rather big speed difference when Auto gets broken.
It's not a big deal to be forced to set manual channels... But not needing to care about it is a nice bonus.
 

JDB

Very Senior Member
I've used Smart Connect on my AX88 with Auto channel for a long time. In the early firmware I had to use manual channels to get full speed on WiFi. Then it worked just fine until .16 (I think it was) where it reverted to the same slow connection. Yet again being forced to use manual channels. And this is just a single router. Same channel in both Auto and Manual. Everything identical. Just not using Auto channel. 286 (or something) vs 1200, rather big speed difference when Auto gets broken.
It's not a big deal to be forced to set manual channels... But not needing to care about it is a nice bonus.
Interesting. Maybe the 20/40/80(/160)MHz bandwidth selection code has been having some attention over the last few releases then. It’s a little understood or noticed option within Wi-fi so could definitely have been missed by the masses thus far.

Very difficult to analyse as the router will drop down without notice even if you select a high number should it deem it required to avoid crowding the airwaves (it is part of the specification).
Each 20Mhz will provide ~430Mbps max PHY link speed on most adaptors so your quoted speeds would suggest 20Mhz (286ish would be reasonable) vs 80Mhz (1300 is usually the max as most adaptors only go to 3x3) is the cause.

My Mac reports the channel width offered by the Router in the Wifi analyser, I assume some scanner for Windows can do the same.


Sent from my iPhone using Tapatalk
 

swejuggalo

Regular Contributor
Interesting. Maybe the 20/40/80(/160)MHz bandwidth selection code has been having some attention over the last few releases then. It’s a little understood or noticed option within Wi-fi so could definitely have been missed by the masses thus far.

Very difficult to analyse as the router will drop down without notice even if you select a high number should it deem it required to avoid crowding the airwaves (it is part of the specification).
Each 20Mhz will provide ~430Mbps max PHY link speed on most adaptors so your quoted speeds would suggest 20Mhz (286ish would be reasonable) vs 80Mhz (1300 is usually the max as most adaptors only go to 3x3) is the cause.

My Mac reports the channel width offered by the Router in the Wifi analyser, I assume some scanner for Windows can do the same.


Sent from my iPhone using Tapatalk
Just tried the .19 Alpha 1 to my router. That one has a functional Auto channel mode again.

Sent from my IN2023 using Tapatalk
 
  • Like
Reactions: JDB

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top