Check which process is spinning up the SSD - RT-AC66U_B1

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

bibekpd

New Around Here
Hi all,

Recently purchase the Asus RT-AC66U_B1 to replace my Virgin Media Router. So far, working great. Yesterday, loaded the wrt-merlin firmware for AC68 release 384.15 and have been playing around with it a little bit.

I have a Samsung M3 1.5TB HDD ext drive (manufactured by Seagate I beleive) which is connected to the front port via USB3.0. It is formatted as NTFS and set up to use Download Master / FTP / Samba all of which work fine. While I was looking around the settings page, I came across the Enable HDD Hibernation (Administration > System) setting and though Ah! great, ill enable this so my drive isn't sitting there spinning 24/7.

Last night, I changed the log to debug mode and was watching the processes and noticed something weird. The drive was spinning down after 60s as specified however within 3-4mins, it was spinning up again. At this point, nothing that I am aware of was using the drive (not download master, no PC's or Laptop) which leads me to my question.. Is there a way to check which process could be spinning up the drive?

Fact that it spins down for a few mins fills me with confidence that the drive supports it although I must admit I cannot find any info on this from Samsung or Seagate.

Any help would be greatly appreciated.

Have posted a snippet of the system log below:
Code:
Apr  4 16:21:42 sd-idle-2.6[5699]: spinning up /dev/sda after 1 mins 1 secs
Apr  4 16:22:42 sd-idle-2.6[5699]: spinning down /dev/sda after 1 mins
Apr  4 16:23:13 sd-idle-2.6[5699]: spinning up /dev/sda after 31 secs
Apr  4 16:23:58 kernel: nvram: consolidating space!
Apr  4 16:24:43 sd-idle-2.6[5699]: spinning down /dev/sda after 1 mins 30 secs
Apr  4 16:27:15 sd-idle-2.6[5699]: spinning up /dev/sda after 2 mins 32 secs
Apr  4 16:28:15 sd-idle-2.6[5699]: spinning down /dev/sda after 1 mins
Apr  4 16:29:35 kernel: nvram: consolidating space!
Apr  4 16:29:46 sd-idle-2.6[5699]: spinning up /dev/sda after 1 mins 31 secs
Apr  4 16:31:16 sd-idle-2.6[5699]: spinning down /dev/sda after 1 mins 30 secs
Apr  4 16:31:47 sd-idle-2.6[5699]: spinning up /dev/sda after 31 secs
Apr  4 16:32:20 rc_service: httpd 255:notify_rc restart_firewall
Apr  4 16:32:21 nat: apply nat rules (/tmp/nat_rules_eth0_eth0)
Apr  4 16:32:23 HomeAsus:  sh /opt/S50asuslighttpd.1 firewall-start
Apr  4 16:32:23 HomeAsus:  sh /opt/S50downloadmaster.1 firewall-start
Apr  4 16:32:35 rc_service: httpd 255:notify_rc restart_firewall
Apr  4 16:32:35 nat: apply nat rules (/tmp/nat_rules_eth0_eth0)
Apr  4 16:32:37 HomeAsus:  sh /opt/S50asuslighttpd.1 firewall-start
Apr  4 16:32:37 HomeAsus:  sh /opt/S50downloadmaster.1 firewall-start
Apr  4 16:34:47 sd-idle-2.6[5699]: spinning down /dev/sda after 3 mins
Apr  4 16:35:38 kernel: warning: `vsftpd' uses 32-bit capabilities (legacy support in use)
Apr  4 16:35:48 sd-idle-2.6[5699]: spinning up /dev/sda after 1 mins 1 secs
Apr  4 16:37:48 sd-idle-2.6[5699]: spinning down /dev/sda after 2 mins
Apr  4 16:41:20 sd-idle-2.6[5699]: spinning up /dev/sda after 3 mins 32 secs
Apr  4 16:42:20 sd-idle-2.6[5699]: spinning down /dev/sda after 1 mins
Apr  4 16:46:21 sd-idle-2.6[5699]: spinning up /dev/sda after 4 mins 1 secs
Apr  4 16:47:21 sd-idle-2.6[5699]: spinning down /dev/sda after 1 mins
Apr  4 16:48:52 sd-idle-2.6[5699]: spinning up /dev/sda after 1 mins 31 secs
Apr  4 16:49:52 sd-idle-2.6[5699]: spinning down /dev/sda after 1 mins
Apr  4 16:51:23 sd-idle-2.6[5699]: spinning up /dev/sda after 1 mins 31 secs
Apr  4 16:52:53 sd-idle-2.6[5699]: spinning down /dev/sda after 1 mins 30 secs
Apr  4 16:56:54 sd-idle-2.6[5699]: spinning up /dev/sda after 4 mins 1 secs
Apr  4 16:57:54 sd-idle-2.6[5699]: spinning down /dev/sda after 1 mins
Apr  4 17:01:56 sd-idle-2.6[5699]: spinning up /dev/sda after 4 mins 2 secs
Apr  4 17:02:56 sd-idle-2.6[5699]: spinning down /dev/sda after 1 mins
Apr  4 17:06:57 sd-idle-2.6[5699]: spinning up /dev/sda after 4 mins 1 secs
Apr  4 17:07:57 sd-idle-2.6[5699]: spinning down /dev/sda after 1 mins
Apr  4 17:11:58 sd-idle-2.6[5699]: spinning up /dev/sda after 4 mins 1 secs
Apr  4 17:12:58 sd-idle-2.6[5699]: spinning down /dev/sda after 1 mins
Apr  4 17:13:29 sd-idle-2.6[5699]: spinning up /dev/sda after 31 secs
Apr  4 17:15:00 sd-idle-2.6[5699]: spinning down /dev/sda after 1 mins 31 secs
Apr  4 17:17:01 sd-idle-2.6[5699]: spinning up /dev/sda after 2 mins 1 secs
Apr  4 17:18:01 sd-idle-2.6[5699]: spinning down /dev/sda after 1 mins
Apr  4 17:21:47 kernel: nvram: consolidating space!
Apr  4 17:22:02 sd-idle-2.6[5699]: spinning up /dev/sda after 4 mins 1 secs
Apr  4 17:23:32 sd-idle-2.6[5699]: spinning down /dev/sda after 1 mins 30 secs
 
Last edited:

ColinTaylor

Part of the Furniture
Setting the spindown time to 60 seconds is far too short (as you have discovered). 300 or 600 seconds would be a better choice.

Any process that is configured to access the HDD could be waking it up. IIRC Download Master does this even when not actively downloading anything. Samba is another obvious candidate because any device on the LAN could be periodically attempting to access the shares.

As the problem is easy to observe you could try temporarily disabling the above processes to see if they are the cause.
 

john9527

Part of the Furniture
You can also try to change the setting
Memory Management: Regularly flush caches (default: Yes), to No
on one of the Tools pages.

When this is set to Yes, even just navigating the gui can cause the disk to spin up.
 

bibekpd

New Around Here
Setting the spindown time to 60 seconds is far too short (as you have discovered). 300 or 600 seconds would be a better choice.

Any process that is configured to access the HDD could be waking it up. IIRC Download Master does this even when not actively downloading anything. Samba is another obvious candidate because any device on the LAN could be periodically attempting to access the shares.

As the problem is easy to observe you could try temporarily disabling the above processes to see if they are the cause.
Thanks!, Thats one way of finding it out I suppose. I'll give this a go later on tonight and enable things one at a time to see which one(s) might be the culprit.
 

bibekpd

New Around Here
You can also try to change the setting
Memory Management: Regularly flush caches (default: Yes), to No
on one of the Tools pages.

When this is set to Yes, even just navigating the gui can cause the disk to spin up.
Thanks!, have changed that to no although sounds like a good thing to do. Out of curiosity, when this is disabled, how often is the cache flushed? I suppose setting up a restart schedule would perhaps to fill the void?
 

john9527

Part of the Furniture
Thanks!, have changed that to no although sounds like a good thing to do. Out of curiosity, when this is disabled, how often is the cache flushed? I suppose setting up a restart schedule would perhaps to fill the void?
No need to do anything....linux will handle it on it's own.
Was primarily put in to appease those that don't like to see high memory use (even though linux is designed to use all the memory it can, unlike windows).
 

Ronald Schwerer

Very Senior Member
Am I missing something here? It's an SSD - no spin-up/spin-down. The hibernation accomplishes nothing significant. You are not saving anything since the current keeping the SSD controller awake is constant. Just turn that setting off.
 

john9527

Part of the Furniture
Am I missing something here? It's an SSD - no spin-up/spin-down. The hibernation accomplishes nothing significant. You are not saving anything since the current keeping the SSD controller awake is constant. Just turn that setting off.
Duh...of course. In fact, I believe that doing 'spindown' on SSDs is not recommended.
 

ColinTaylor

Part of the Furniture

bibekpd

New Around Here
Am I missing something here? It's an SSD - no spin-up/spin-down. The hibernation accomplishes nothing significant. You are not saving anything since the current keeping the SSD controller awake is constant. Just turn that setting off.
Sorry for the confusion, it is a hard drive rather than solid state drive.
 

bibekpd

New Around Here
Turned off "Regularly flush Caches" under Memory Management as suggested by john9527 and hdd has been hibernating for over 30 mins now whilst everything still enabled as per my original post.
Obviously, no other devices on the network are accessing the HDD for any reason so must be just that option causing the issue. Looks like sorted for now but will report back if anything changes! Thanks all for your input!
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top