Closing OpenVPN client kill WAN connection

  • SNBForums will be unavailable for about 2 hours TOMORROW 23 January starting around 2PM EDT for a server changeover.

    All accounts and posts will be preserved.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Steve Blencowe

New Around Here
Hi, I have an ASUS AC86U running the latest non beta Aususwrt-Merlin.

I set up an OpenVPN connection (using PureVPN .ovpn config files) and set up the split tunnelling feature to have VPN on one specific device.

This works fine.

However whenever I close the VPN connection on the router I loose connection to the WAN - which requires a router reboot to solve.

Has anyone else experienced this?

Thanks
 

Martineau

Part of the Furniture
Hi, I have an ASUS AC86U running the latest non beta Aususwrt-Merlin.

I set up an OpenVPN connection (using PureVPN .ovpn config files) and set up the split tunnelling feature to have VPN on one specific device.

This works fine.

However whenever I close the VPN connection on the router I loose connection to the WAN - which requires a router reboot to solve.

Has anyone else experienced this?

Thanks
Do you have the KILL-switch ENABLED?
 

Martineau

Part of the Furniture
Not sure! At work now so will check tonight. Thanks
You can copy and paste the following command into a SSH command window:
Code:
ip rule;for I in 1 2 3 4 5; do echo -e "ovpnc$I table 11$I";ip route show table 11$I;done
which should prove if the 'prohibit' (aka KILL-switch) keyword is ENABLED for any of the VPN clients.
 
Last edited:

Steve Blencowe

New Around Here
I have the kill switch option off - "Block routed clients if tunnel goes down" set to No. Tried again. Set up to route Nvidia Shield via VPN. Worked fine. Stopped VPN and WAN connection severed until I reboot router.

If I remove the split tunnelling the VPN works for everything going via the router and when I turn it off all is OK.

Odd.
 

Steve Blencowe

New Around Here
You can copy and paste the following command into a SSH command window:
Code:
ip rule;for I in 1 2 3 4 5; do echo -e "ovpnc$I table 11$I";ip route show table 11$I;done
which should prove if the 'prohibit' (aka KILL-switch) keyword is ENABLED for any of the VPN clients.
I have run this and cannot see any mention of 'prohibit'.
 

Steve Blencowe

New Around Here
Found a workaround. After closing the VPN - and left with no WAN I click on 'Internet Status' and turn off the internet connection and back on again. This regains my WAN connection. Not great but at least I don't need to reboot the router each time.
 

Butterfly Bones

Very Senior Member
Found a workaround. After closing the VPN - and left with no WAN I click on 'Internet Status' and turn off the internet connection and back on again. This regains my WAN connection. Not great but at least I don't need to reboot the router each time.
When it happens again, open an SSH terminal and enter this. Note the underscore.
Code:
service restart_wan
If that works, there are scripts here than can check for the wan up / down and issue that command via script and / or cron job.
 

Steve Blencowe

New Around Here
When it happens again, open an SSH terminal and enter this. Note the underscore.
Code:
service restart_wan
If that works, there are scripts here than can check for the wan up / down and issue that command via script and / or cron job.
Yes running that script in SSH brought the WAN back. Thanks. Where are the scripts you mention?
 

Butterfly Bones

Very Senior Member

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top