Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Configure the port used for SIP helper

Discussion in 'Asuswrt-Merlin' started by Mistermoonlight, Feb 26, 2013.

  1. Mistermoonlight

    Mistermoonlight Regular Contributor

    Feb 16, 2013
    Running latest Merlin build for rt-n66u. I am running a voip device on the lan. I have fowarded the ports from outside for rtp and sip to the voip device. When i am doing an outgoing call, there is an rtp stream that can go from wan to lan correctly (here the voice), but the rtp stream from lan to wan gives a lot of problem (usually is simply not there at all and we hear silence.

    I have tried using the disable net helper function, but enable/disable changes nothing. I guess that i need the sip helper working to solve my problem, but the SIP port used by my device is not the standart sip port 5060.

    How can i reconfigure the sip helper to use a different sip port than the default 5060?

    Any other idea?

  2. RMerlin

    RMerlin Part of the Furniture

    Apr 14, 2012
    Untested, by try this:

    1) Disable the SIP helper
    2) Create an init-start script, with the following (change the port as appropriate):

    modprobe ip_conntrack_sip ports=5060
    3) Reboot

    Check the Wiki on Github for details on how to use User Scripts.
  3. Mistermoonlight

    Mistermoonlight Regular Contributor

    Feb 16, 2013
    Thanks for the idea.

    It seems to be more something like this that i tried to use for the init-start script (sip port is 5085 for me):

    rmmod nf_nat_sip.ko
    rmmod nf_conntrack_sip.ko
    modprobe nf_conntrack_sip ports=5085
    modprobe nf_nat_sip

    but i discovered later than the problem was not related to the router so i didn't test any further.

    Thanks anyway

Share This Page