Configuring network time on Orbi

agneev

Occasional Visitor
Hello!

I'm running Voxel Firmware on my RBRs.

During startup, if there's no internet connection (or DNS is down), the router is not able to set the proper time and as a result, several applications that depend on the availability of correct time, fail to start.
Fortunately, my ISP runs a time server on the gateway (that is available as long as their gateway is up).

Is there a way to change how the router obtains time? I'm not able to find any documentation on this.
 

HELLO_wORLD

Very Senior Member

R. Gerrits

Senior Member
I forgot to mention that I was referring to setting the time from a NTP server! @HELLO_wORLD
stopping and starting the ntpclient would probably force it to immediately try setting the time.

i.e doing:
Code:
/etc/init.d/ntpclient restart

note for some reason on my R7800, if I restart that service, it does only stop the service and doesn't restart it.

So for me the only thing that is working is:
Code:
/etc/init.d/ntpclient stop; /etc/init.d/ntpclient start

Seems that Netgear made the mistake of giving the init-script the same name as the binary. -> During the stopping, it does a killall ntpclient -> it then kills both the ntpclient AND the ntpclient init-script -> the start part is never executed.

I suspect that the same thing will happen on an RBR.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top