What's new

Connection issue with Chromecast and Asus RT-AX58U

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Josef Karlsson

New Around Here
Hi!

I have bought a new rt-ax58u router and i am having some issues with the connection to my chromecasts. The wifi itself works flawless, both in smart connect mode and with separate bands (2.4 & 5 ghz). But when i try to connect my chromecasts to the new wifi, i can only get as far as to the wifi setup/selection screen in the google home app. The chromecasts try to connect, but can't get access. I have tried connecting them to another wifi (mobile hotspot) aswell as a guest network created on the new router and that works fine aswell.

According to one of Google's tech support there is some built in AP isolation or other setting that i can't change and therefor the router is not compatible with Chromecast. Is this really the case? Attaching router settings. I have a password, but removed it for screenshot. I have updated the firmware on the router.

Thanks in advance for help/input!
 

Attachments

  • routersettings11.jpg
    routersettings11.jpg
    64.9 KB · Views: 1,346
  • routersettings12.jpg
    routersettings12.jpg
    58.8 KB · Views: 1,330
you could try to disable AX mode, airtime fairness and universal beamforming.
 
According to one of Google's tech support there is some built in AP isolation or other setting that i can't change and therefor the router is not compatible with Chromecast. Is this really the case?

No, this should not be the case... the router would not be much use if it isolated clients.

Strange that it works on a guest WLAN but not the regular WLAN.

OE
 
Protection Management Frames is set to Required, Chromecast mostly likely not compatible. I would set to Capable if you want to use Wifi Agile Multiband, if you not gonna use set it to disable.

@OzarkEdge, Chromecast does have issue if AP isolation is on, that is why google says turn it off.
 
@OzarkEdge, Chromecast does have issue if AP isolation is on, that is why google says turn it off.

Of course. OP shows it OFF. Google did not say turn it OFF... Google said 'the router is not compatible with Chromecast', which I suggested is not true... OP proved the router's guest WLAN works with Chromecast... that sounds compatible to me.

OE
 
Last edited:
Protection Management Frames is set to Required, Chromecast mostly likely not compatible. I would set to Capable if you want to use Wifi Agile Multiband, if you not gonna use set it to disable.

@OzarkEdge, Chromecast does have issue if AP isolation is on, that is why google says turn it off.

This did the trick! I am now able to run the chromecasts on smart connect and with all other settings (that i want) enabled. Thank you so much Hawk, Grisu and OE for your time and input!
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top