Consequences of RT-AC68U USB flash failure

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

pirx73

Regular Contributor
Hello gents. Recently i got a very strange glitch with my trusty AC-68U.
Two days ago in a middle of day internet just stopped working. Exactly like that. No tinkering with router involved.
Router just stopped forwarding traffic. Restarting router yielded very weird results - no DCHP requests were accepted.
Then i tried again, but turned it off for several minutes. I was able to access router but again - no internet.
I called my ISP and they reported that no DHCP requests from my router are incoming.
Scripts on flash (32GB) were also inaccessible so i pulled it out from the router.
Suddenly... router began to work.
I turned my suspicions towards flash then and ran usb flash tester. Ouch! Many write and read failures.
So root cause - faulty USB flash stick. Problem solved, just replace it. I had 8GB stick laying arround and i tested it thoroughly to be sure it is fine.
I also plugged it into USB 2.0 port instead of 3.0 just to make sure it heats up less.

I do not run any custom DHCP or routing services which could use flash, all i have is in my signature.
Because of swap file located on flash? But router was not so overloaded that it would swap constantly.

Okay, but what puzzles me is why malfunctioning flash killed router's basic functions?
Any ideas?
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top