What's new

Copying a file from server when connecting segments to router directly kills internet and network

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Regular Contributor

I've been trying to solve a problem with my network where if I run any torrent program and then try and copy a large file from my server to ANY PC on my network it kills the Internet and the PCs on the LAN become unresponsive. The problem may also apply to heavy HTTP traffic too but I haven't tested that.

I'm sorry if "segments" is the wrong term.

For as long as I can remember I've been running my home LAN with multiple switches and one of those connected to the router. Recently trying to solve a problem that turned out to be a faulty internet termination device issue I removed one of the switches and upgraded from an RT-AC87u to a RT-AC88u

As the 88u has 8 gigabit ports I ran all LAN segments directly to the router and removed one of my Netgear GS108T-V2 switches. Since doing that when ever I copy a large file from my Win 2012 R2 server from ANY PC on the LAN when uTorrent (or any of several other torrent clients), is actively uploading or downloading on the same or any other PC on the network the Internet will die (As in drop from 100Mbs to 1Mbps down). Everyone's internet becomes unresponsive as does everything they are doing on their PCs. Games disconnect, programs just stop and crash.

My LAN structure is documented here https://www.snbforums.com/threads/c...nd-network-but-b-a-is-fine.44156/#post-375522 (There are two images, one that works one that doesn't).

If I put the switch back between the LAN segments and the router everything works perfectly. Any PC can hammer the internet via P2P, HTTP or FTP, run online games, surf, copy files to and from the server simultaneously and the internet doesn't flinch.

I've been told "it can't possibly be the router as the switch in the router cannot possibly cause or experience such a problem. The 8 ports can send and receive at 1Gbps simultaneously, so there's no way that's the problem".

Despite that, it was suggested I post here (I guess in the hope that maybe it's a Merlin configuration issue?)

I'm told the extra switch is hiding the real problem (as opposed to "solving" the problem).

Any advice on what might be causing this or how I can track this down would be greatly appreciated.

On another site when I was first trying to get help for this, another forum member added that he too could reproduce the exact same situation on his network, so despite being told my network is "unique" it appears it's not.
The RT-AC88U is unusual in that LAN ports 5 to 8 are managed by a separate Realtek switch chip. This is linked to the other Broadcom switch chip through IIRC a 1Gb link. So this creates a bottleneck between ports 1-4 and 5-8.

It's also possible that the way this is implemented might create some additional peculiarities, see the SNB bidirectional LAN test here.

As you only appear to have 4 LAN connections to your router try putting them all into ports 1 to 4 (or 5 to 8) and see if that makes a difference.
Hello Colin,

Thanks for your reply.
This does seem to be the issue.
All 3 data and the 1 VOIP segments are on ports 1 - 4 and there are no issues.
Put any of the data segments on ports 5 - 8 and the problem occurs.

thank you so much!
Wow.. that's stupid. Fake 8 ports.
Is there a way to make them communicate with each other?

Like compatible mode?

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!