Voxel Custom firmware build for Orbi LBR20 v. 9.2.5.2.27SF-HW

Voxel

Part of the Furniture
Continuation of:

https://www.snbforums.com/threads/c...bi-lbr20-v-9-2-5-2-24sf-hw.73983/#post-708327
https://www.snbforums.com/threads/custom-firmware-build-for-orbi-lbr20-v-9-2-5-2-25sf-hw.74426/
https://www.snbforums.com/threads/custom-firmware-build-for-orbi-lbr20-v-9-2-5-2-26sf-hw.75558/

New version of my custom firmware build: 9.2.5.2.27SF-HW.

Changes (vs 9.2.5.2.26SF-HW):

1. Toolchain: Go is upgraded 1.17.2->1.17.5.
2. Toolchain: gdb is upgraded 10.1->11.1.
3. Fix lacking build of 'kmod-ipt-ipset' (ipset).
4. wireguard package is upgraded 1.0.20210606->1.0.20211208.
5. lighttpd package is upgraded 1.4.61->1.4.63.
6. curl package is upgraded 7.79.1->7.80.0.
7. iproute2 package is upgraded 4.0.0->4.4.0.
8. xtables-addons package is upgraded 2.10->2.14.
9. ethtool package is upgraded 5.14->5.15.
10. iw package is upgraded 5.9->5.16.
11. ncurses package is upgraded 6.2->6.3.
12. ca-certificates package is upgraded 20210119->20211016.
13. bind package is upgraded 9.17.19->9.17.20.
14. Default congestion control algorithm is changed to 'highspeed'.
15. HTCP/ILLINOIS congestion control algorithms are added.
16. Slight optimization of some components.
17. Host tools: various updates.

The link is:

https://www.voxel-firmware.com (thanks to vladlenas for his help with hosting).

Voxel.
 

lukeskywalker

New Around Here
Hi Voxel, I just got a cheap LBR20 on Amazon and updated it to the latest STOCK fw.

I have also a RBS20 attached to it.

I will install your latest FW I am happy to provide feedback and work with you on this.

I am familiar with GitHub too if you want to discuss it there.

My main complaints (stock FW) are:

  1. If you enable mobile failover, you cannot access the VLAN / Bridge Settings (this is a problem since my fiber PPoE connection requires those settings
  2. you cannot receive a notification when mobile failover is activated
  3. If I manually trigger a mobile failover, I could not get the router to switch back to the wired connection once it becomes available again
  4. Once a day I lose connectivity, the router does not failover to mobile...and I have no clue why

Before I move to your cfw, can you please let me know if my settings are going to be saved or everything will need to be reconfigured?

Thanks!!!
 

lukeskywalker

New Around Here
Hello folks, I am posting here, as I could not find other infos, except the readme file on the Voxel Firmware Website.

How do I login using SSH? Do I need to setup the keys as per the readme file?

Or is there a default password to use?

I suppose the user is
Code:
root
 

mith_y2k

Regular Contributor
Hello folks, I am posting here, as I could not find other infos, except the readme file on the Voxel Firmware Website.

How do I login using SSH? Do I need to setup the keys as per the readme file?

Or is there a default password to use?

I suppose the user is
Code:
root

by default the user is root and password the same as the web interface. Setting up the keys is for security and faster login
 

lukeskywalker

New Around Here
by default the user is root and password the same as the web interface. Setting up the keys is for security and faster login
Thank you, there seems to be a deeper issue here.

  1. I have accessed the
    Code:
    debug.htm
    page to enable telnet and try to troubleshoot the password issue
  2. Even via telnet, I could not access with my standard web-ui password
  3. So I tried to reset the password via web-ui, I kept getting message "old password not correct"
  4. Lo and behold...after flashing Voxel firmware, the router accepts ANY password!!!!
  5. I can login via web/ssh/telnet with just any password and changes done via
    Code:
    passwd
    command with the root user via SSH are not stored
  6. I tried a hard reboot (power cycle) and changed the password via web-ui
  7. Now the password is stored for SSH and Web UI.
  8. But the Mobile connection stopped working: I tried to simulate an outage removing the WAN cable and also tried to force the Mobile connection always on, but the router cannot reach the internet.
Please help me out, I do not wanna revert to the original FW, the Voxel FW is way more stable, but I can't either have the router WITHOUT its mobile data connection...
 
Last edited:

Voxel

Part of the Furniture
I do not quite understand how you were able to do this. SSH is working with root and WebGUI password immediately after flashing my version.

Probably you should reset your LBR to factory settings and to setup it anew. It is better to flash temporary the stock 2.5.2.20, to perform reset to factory and to flash my version again. After that you can setup it from the scratch. WebGUI password,Wi-Fi ssid etc.

Voxel.
 

lukeskywalker

New Around Here
Update on my previu
I do not quite understand how you were able to do this. SSH is working with root and WebGUI password immediately after flashing my version.

Probably you should reset your LBR to factory settings and to setup it anew. It is better to flash temporary the stock 2.5.2.20, to perform reset to factory and to flash my version again. After that you can setup it from the scratch. WebGUI password,Wi-Fi ssid etc.

Voxel.
Once again:), thank you very much for the prompt reply Voxel!
I am puzzled as well. The firmware flash went well, since:

  1. I can see the new firmware branding
  2. I can enable Telnet
  3. The LBR20 finally stopped getting stuck randomly
However these issues make me think that something went wrong somewhere:
  • the lack of persistent storage (the root user still has the `tmp` folder set as home,
  • the lack of 4g/3g connectivity, despite having full bars
Before I go ahead and factory reset and reinstall everything, is there any debugging we can do together?
 

lukeskywalker

New Around Here
Ok, so I did a factory reset, re installed the original FW and installed the Voxel FW again.
For a moment I was able to see the root directory being different from TMP, but after a reboot, it went back to TMP.
Also, I cannot find the SMS function in the menu, is it normal? It was there with the last Netgear FW.
 

lukeskywalker

New Around Here
Brief update.

The good:
  • I have my persistent storage `tmp/circle/`
  • The LTE function works just fine
  • The ssh password is stored correctly
The nice to have:

  • SMS (receive / send)
  • A way to know what connections are blocked by the router: e.g.: I can get a program to work only if I put a device in the DMZ, otherwise the program/app in question does not work. Is there a way of checking what connections are blocked/dropped for a specific client?

11 Jan 2022

I cannot pair the RBS20 anymore
The list of connected devices is empty

I suspect my hardware is faulty...Need to send everything back to Amazon and try again
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top