Custom firmware build for R7800 v. 1.0.2.64SF

Voxel

Part of the Furniture
Continuation of
. . .
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-63sf.54782/

New version of my custom firmware build: 1.0.2.64SF.

Changes (vs 1.0.2.63SF):

1. Attempt to fix the issue with ReadyCLOUD in AP mode.
2. Default ReadyCLOUD version is upgraded 20170914->20180619.
3. Fixing the issue with OpenVPN server (WebGUI).
4. OpenVPN is upgraded 2.4.6->2.4.7.
5. tar package is upgraded 1.30->1.31.
6. curl package is upgraded 7.63.0->7.64.0.
7. unbound package (used in stubby) is upgraded 1.8.3->1.9.0.
8. getdns package (used un stubby) is upgraded 1.4.2->1.5.0.
9. stubby package is upgraded 0.2.3->0.2.4.
10. libsodium package (used in dnscrypt-proxy v.1) is upgraded 1.0.16->1.0.17.
11. libvorbis package is upgraded 1.3.5->1.3.6.
12. ffmpeg package is upgraded 3.2.12->3.4.5.
13. busybox package: patch command is added.
14. busybox package: dos2unix/unix2dos commands are added.
15. Host tools: two components are upgraded (bison, sed).

The link is:

https://www.voxel-firmware.com (thanks to vladlenas for his help with hosting).

P.S.
Maybe I release fw too often :). But a lot of updates. And new version of OpenVPN: it worth a try.

Voxel.
 

ulaganath

Very Senior Member
Gr8 I have to share this.
It’s been 2months your 62f is rocky.

I was Also using a mini router but x4s is also a router maybe overkill but I like the interface of edge x live traffic system which is missing in x4s I know the 3rd part app will give that.

My experience is afterR7000 this router has reached near gig internet speed I was literally getting 118+ even local speed limit to 108-115MB/s

It’s good experience my setup ready for future internet . Of course a lot of factors involved a good cpu and app with good ram and SSD needed for this speed to be achieved constantly I mean a 50gig will be downloaded full 1gbps speed wow post snap and video as possible.


Sent from my iPhone using Tapatalk
 

cordezz

Occasional Visitor
New version of my custom firmware build: 1.0.2.64SF.

Changes (vs 1.0.2.63SF):

1. Attempt to fix the issue with ReadyCLOUD in AP mode.
Thank you Voxel.
I can confirm that it works now. Had to type first “cloud uninstall” and reboot, but then I could register my Readycloud account. :)


BTW: Whats the difference between entware-cortex-a15-3x-initial-generic.tar.gz and entware-cortex-a15-3x-initial-alternative.tar.gz ?
 

Voxel

Part of the Furniture
I can confirm that it works now. Had to type first “cloud uninstall” and reboot, but then I could register my Readycloud account.
Good you could solve this. I had something similar during testing. Something was changed in the stock 1.0.2.62 for AP mode. So I had to add my own init script for ReadyCLOUD installation. And BTW people in official NG forum signal problems with ReadyCLOUD (in bridge mode, but the same for AP mode).


BTW: Whats the difference between entware-cortex-a15-3x-initial-generic.tar.gz and entware-cortex-a15-3x-initial-alternative.tar.gz ?

See:

https://github.com/Entware/Entware/wiki/Alternative-install-vs-standard

Alternative is important for some packages such as e.g. OpenSSH server (it does not accept root account rights for init script).

Voxel.
 

cdysthe

Regular Contributor
Continuation of

P.S.
Maybe I release fw too often :). But a lot of updates. And new version of OpenVPN: it worth a try.

Voxel.

Great new build! And no, you do NOT release too often. Those who do not want to update simply shouldn't. Thank you so much for your excellent work! My router purrs every time I get a new Voxel on it! :)
 
Last edited:

vit5421

Regular Contributor
There is a bug in this version. The router is working after update but password and security questions were lost on both routers and i have to reset the routers and upload the configuration file
So be careful
 

Voxel

Part of the Furniture
There is a bug in this version. The router is working after update but password and security questions were lost on both routers and i have to reset the routers and upload the configuration file
So be careful
It happens on my both routers for 1st time ever. So i guess there is a problem
I think you are mistaken. Maybe you flashed this version from the version < 63SF (or stock 1.0.2.62). Since 1.0.2.63SF I added NG's security enhancement (taken from the stock 1.0.2.62). And it asks for a password by design. Passwords are not stored now in nvram as a plain text so it is why it asks your for a password and security questions.

I've flashed both of my R7800 and first of them four times. No lost passwords.

I think guys would already report this (a lot of reports) in the case of such a bug.

Voxel.
 

vit5421

Regular Contributor
Thank you. I flashed 64sf from 63sf. 63sf flashing was good. It works fine now after reset. The security questions was lost as well on both routers and I can't even activate telnet. I hope it was just my problem then
 

ulaganath

Very Senior Member
Still rocking


Sent from my ASUS_Z01RD using Tapatalk
 

bartj12

Regular Contributor
P.S.
Maybe I release fw too often :). But a lot of updates. And new version of OpenVPN: it worth a try.

Voxel.

Thank you so much for your rock stable firmware!! Upgrading costs like 5 minutes, so keep the updates coming!
 

cdysthe

Regular Contributor
There is a bug in this version. The router is working after update but password and security questions were lost on both routers and i have to reset the routers and upload the configuration file
So be careful

I did not experience the password loss. I have been getting the request for setting a new more secure password though, but that was before the update. All good here.
 

jsmiddleton4

Very Senior Member
Don't know what to tell you just that with kamoj's add in for me I have DNS stalls. Takes too long to resolve.

Also I lost connection to my USB/eSATA attached hard drives.
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top