Voxel Custom firmware build for R7800 v. 1.0.2.81SF & v. 1.0.2.81.1SF

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Voxel

Part of the Furniture
Continuation of
. . .
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-79sf.65364/
https://www.snbforums.com/threads/c...0-2-80sf-v-1-0-2-80-4sf-v-1-0-2-80-5sf.66275/

New version of my custom firmware build: 1.0.2.81SF.

Changes (vs 1.0.2.80.7SF):

1. Toolchain: Go is upgraded 1.15.5->1.15.6.
2. OpenSSL v. 1.1.1 package is upgraded 1.1.1h->1.1.1i (fixing CVE-2020-1971).
3. curl package is upgraded 7.73.0->7.74.0 (fixing CVE-2020-8284, CVE-2020-8285, CVE-2020-8286).
4. OpenVPN is upgraded 2.4.9->2.5.0.
5. proftpd package is upgraded 1.3.6e->1.3.7a.
6. transmission package is upgraded 2.94->3.00.
7. unbound package (used in stubby) is upgraded 1.12.0->1.13.0.
8. nano package is upgraded 5.3->5.4.
9. ubus package is upgraded 2020-10-25->2020-12-04.
10. ffmpeg package is upgraded 3.4.8->4.3.1.
11. logrotate package is upgraded 3.16.0->3.17.0.
12. libcryptoxx final size is reduced to save a space (LTO optimization).
13. Change WebGUI info for OpenVPN 2.4.x->2.5.x.
14. OpenVPN server: add 'CHACHA20-POLY1305' cipher to 'ncp-ciphers' option and change the cipher of downloaded config for Windows clients to 'CHACHA20-POLY1305'.
(Important: it is highly recommended to use 'CHACHA20-POLY1305' if your client is based on v. 2.5.x, much faster,
change your non-Windows client config if possible).

[Edited]

Quickfix/Snapshot version 1.0.2.81.1SF

Changes (vs 1.0.2.81SF):

1. Fix AP mode issue (files: '/etc/init.d/opmode', '/etc/init.d/qca-nss-ecm',
'/www/cgi-bin/firewall_function.sh', C codes of: 'qca-nss-ecm' package).
2. libubox package is upgraded 2020-08-06->2020-12-12.
3. libgcrypt package: optimize for a size.
4. tar package: optimize for a size.
5. Add procps-ng package utilities ('ps', 'top').
(run '/usr/bin/top-procps-ng' or '/usr/bin/ps-procps-ng -aux' from console to check them).


The link is:

https://www.voxel-firmware.com (thanks to vladlenas for his help with hosting).

P.S.

AES-256-CBC vs CHACHA20-POLY1305 (OpenSSL test):

Code:
The 'numbers' are in 1000s of bytes per second processed.
type             16 bytes     64 bytes    256 bytes   1024 bytes   8192 bytes  16384 bytes
aes-256-cbc      46576.28k    60093.73k    64728.87k    65417.50k    65618.19k    66062.63k

Code:
The 'numbers' are in 1000s of bytes per second processed.
type             16 bytes     64 bytes    256 bytes   1024 bytes   8192 bytes  16384 bytes
chacha20-poly1305    46808.96k   106936.64k   246804.29k   275046.06k   285722.71k   276856.72k

Voxel.
 
Last edited:

kokishin

Regular Contributor
Continuation of
. . .
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-79sf.65364/
https://www.snbforums.com/threads/c...0-2-80sf-v-1-0-2-80-4sf-v-1-0-2-80-5sf.66275/

New version of my custom firmware build: 1.0.2.81SF.

Changes (vs 1.0.2.80.7SF):

1. Toolchain: Go is upgraded 1.15.5->1.15.6.
2. OpenSSL v. 1.1.1 package is upgraded 1.1.1h->1.1.1i (fixing CVE-2020-1971).
3. curl package is upgraded 7.73.0->7.74.0 (fixing CVE-2020-8284, CVE-2020-8285, CVE-2020-8286).
4. OpenVPN is upgraded 2.4.9->2.5.0.
5. proftpd package is upgraded 1.3.6e->1.3.7a.
6. transmission package is upgraded 2.94->3.00.
7. unbound package (used in stubby) is upgraded 1.12.0->1.13.0.
8. nano package is upgraded 5.3->5.4.
9. ubus package is upgraded 2020-10-25->2020-12-04.
10. ffmpeg package is upgraded 3.4.8->4.3.1.
11. logrotate package is upgraded 3.16.0->3.17.0.
12. libcryptoxx final size is reduced to save a space (LTO optimization).
13. Change WebGUI info for OpenVPN 2.4.x->2.5.x.
14. OpenVPN server: add 'CHACHA20-POLY1305' cipher to 'ncp-ciphers' option and change the cipher of downloaded config for Windows clients to 'CHACHA20-POLY1305'.
(Important: it is highly recommended to use 'CHACHA20-POLY1305' if your client is based on v. 2.5.x, much faster,
change your non-Windows client config if possible).

The link is:

https://www.voxel-firmware.com (thanks to vladlenas for his help with hosting).

P.S.

AES-256-CBC vs CHACHA20-POLY1305 (OpenSSL test):

Code:
The 'numbers' are in 1000s of bytes per second processed.
type             16 bytes     64 bytes    256 bytes   1024 bytes   8192 bytes  16384 bytes
aes-256-cbc      46576.28k    60093.73k    64728.87k    65417.50k    65618.19k    66062.63k

Code:
The 'numbers' are in 1000s of bytes per second processed.
type             16 bytes     64 bytes    256 bytes   1024 bytes   8192 bytes  16384 bytes
chacha20-poly1305    46808.96k   106936.64k   246804.29k   275046.06k   285722.71k   276856.72k

Voxel.
Hello Voxel.

Just installed 81SF.

Only issue was that I got a warning that 81SF was older than 80.7SF. Just ignored it.

Thank you sir!
 

Sizzlechest

Regular Contributor
Had a strange thing happen after upgrade to 81. Everything was fine for about 30 minutes. Then the 5G WiFi just stopped working. Unplugged the router and restarted it and it seems fine now. I've never seen that happen. Will keep an eye on that.
 

jsmiddleton4

Very Senior Member
"5G WiFi just stopped working"

I've had that happen randomly with upgrades. The fix I've used is to change the 5ghz channel. Power off reboot might fix it too. Seems it needs to be reset.

Edit: Also even though I have one AX client that can do HT160 and could use it, if I enable it in the router the 5ghz is a tad unstable.
 
Last edited:

ianvajra

New Around Here
Thanks very much Voxel for all your work with 81 :) Installed in my main and AP R7800s.

Would I understand correctly that 81 'includes' the recent Netgear fimware 1.0.2.76?

I am also interested in whether 81 includes a fix for the AP uploading bug, and whether that fix applies over Ethernet too (though if I remember correctly, that was 'fixed by Netgear' in their firmware 1.0.2.74). I think you (Voxel) expressed some doubt whether it had indeed been fixed...
 

Giudi001

Occasional Visitor
"5G WiFi just stopped working"

I've had that happen randomly with upgrades. The fix I've used is to change the 5ghz channel. Power off reboot might fix it too. Seems it needs to be reset.

Edit: Also even though I have one AX client that can do HT160 and could use it, if I enable it in the router the 5ghz is a tad unstable.
Dear,
for me same problem about 5Ghz with this firmware, I have frequent disconnections of all 5GHZ clients for about 1 min, the 5GHZ network disappears from the list of available wifi.
Config page side and kamoj menu, I see that the device is up.
. Downgrade to FW:V1.0.2.80.4SF (Voxel) all returns ok.
 

LeKeiser

Regular Contributor
Hello,

That's weird. I've upgraded the firmware yesterday and I haven't seen any disconnection last evening with my laptop.
When you say they happen frequently, it's like every 5 mins? 10? How long does it last?
 

Giudi001

Occasional Visitor
Hi ,
yesterday evening when switch on vodafone TV, system 5ghz crash every 1-2 mins,
 
Last edited:

jsmiddleton4

Very Senior Member
5ghz every 1-2 minutes.

That’s what happens and for me the fix as always been to manually change the channel for the 5ghz channel, save, etc.
 

Giudi001

Occasional Visitor
hello Guys, update, I would say do not be firmware problem, even with the downgrade I have the same disconnect problems, which happen randomly, and last about 30-40 sec, the 5GHZ network disappears.
I tried today to:
clear via telnet the nvram with the usual commands, downgrade to original Netgear firmware, then I put the .81 firmware back without restoring settings, it lasted a few hours and then usual problem.
Downgrade to version .79 and again and the same problem, idem with the .80.

Question, did you think your router failed? log side i don't see anything
 

Voxel

Part of the Furniture
whether 81 includes a fix for the AP uploading bug

Please check the version 81.1SF (updated, the very first post in this thread). But... To say true, let me say this using more right words. WAN<->LAN connection (how to say it polite enough...) at least is not faster vs LAN<->LAN. So if your goal it to free additional LAN port, just use 81.1SF attaching your cable to WAN port (in AP mode). If no such goals: it is better to continue using LAN port in AP mode. At least I still do use LAN. I have a bit overcomplicated environment when my R7800 in AP mode is connected to other LAN using LAN port. So for example my laptop is attached as:

laptop <-> LAN port [R7800] LAN port <-> ORBI Satellite <-> ORBI Router <->Internet

or

laptop <-> LAN port [R7800] LAN port<-> ORBI Satellite <-> LAN

so if I change R7800 LAN port to R7800 WAN port I do not see any profits. Rather vice versa. Neither speed nor other stuffs.

Voxel.
 
Last edited:

Voxel

Part of the Furniture
Add-on:

Use of WAN port of R7800 in AP mode (as well as any other AP) has a sense in the 'classic' installation, something like:

ROUTER<->AP1<->LAN
^
|
V
AP2
^
|
V
LAN


etc.

But if something more complex...

Voxel.
 

Voxel

Part of the Furniture
Last edited:

Voxel

Part of the Furniture
Regarding some reports (a la issues) of Wi-Fi connection: no any changes in Wi-Fi for a long time. Should not be any new problems flashing 81SF/81.1SF. Just a hint: really check your channel. E.g. if you selected the channel DFS, it could be changed unexpectedly. I face it sometimes with one of my R7800 (64(DFS) -> 100(DFS) or so). Specific of DFS.

Voxel.
 

Giudi001

Occasional Visitor
dear Voxel,
i've just upgrade to 81.1 but i've very slow wifi performance with this version with same settings!!!!
With this 81.1, speed test in download is 300Mb and 200mb in upload. With old firmware, like .79, speed test in download 910Mb and 200mb in upload with 5GHZ wifi. I've just tested this with my laptop.
Same situation with my iphone xr, with 81.1 firmware donloadw 280-300mb and with .79 firmware--->662mb.
About my settings, i've vodafone gigabit fiber direct into r7800 from ONT with eth cable.
About 5GHZ channel my config set to 44, if i change to 36 or 48 slow wifi performance like .81.1 firmware, only with 44 channel i've this performance

thanks
I
 

MinkyMomo

Occasional Visitor
I just upgraded to 81.1SF and as far as I can tell, 5GHz performance on channel 36(+40,44,48) is unchanged with respect to 81SF. To my knowledge, there are no radars in my vicinity that could trigger DFS.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top