Voxel Custom firmware build for R7800 v. 1.0.2.89SF

NetBytes

Regular Contributor
Update I realize I can’t edit this from the confit file. Could you help me with the path to
nvram set disable_dnsmqasq=1
nvram set disable_dnsmasq=1
nvram commit

Or will correcting the spelling of dnsmqasq fix all issues.
thanks
Just in case this might have confused you,
You only (might) need to do this if you are using your R7800 in AP Mode.
Don't do this for normal router operation.
 

RMinNJ

Regular Contributor
perhaps but my router still does not work after firmware upgrade from V1.0.2.88SF to V1.0.2.89SF
I am using it in Router mode and not AP mode. I thought maybe the NVRAM error message I was getting is still related.

So I thought I would try and chase down this problem.

I still have no internet but can see all of my devices from the GUI router page. I have tried a reboot a few times. I might do it again.

If nothing else I have ssh into my router and set up keys to do so and can open nano.

I am still stuck with no internet. It seems like my WAN port has just dissapeared. Will be happy to post a log file or anything that might help me out. I have tried reverting back to the 88SF firmware and no luck there either

When opening a file in nano for some reason there is no txt files there to edit.

half thinking about going and trying to find another router just to get off my phones hotspot.
Um..did you flashback to an older version and get back working internet?
 

cpunerd

New Around Here
I am on current firmware. So, I learned how to telenet and set up ssh into the router with certificates made with putty.

I used Voxel readme document. The snbforums.com/threads, TheWorkaroundTech creator on youtube had 2 videos I watched that helped me find the telenet option in the browser debug.

I rebooted several times. Found some suspect cable connections. Which I suspect where the issue. I don't know exactly what happened that caused the initial failure. Could have been large hound dog. I guess I need to make some new cables.

I am still unsure why I didn't find any editable files with ssh and nano. But I rooted into the router and was able to look at the dir and open nano.

Should I turn the telenet option back off?

Sorry for muking up the forum here. I deleted some stuff.

If anyone wants to read my journey, I will attach a .txt file with my posts. haha.
 

Attachments

  • journey.txt
    3.4 KB · Views: 48

gobble

Occasional Visitor
Voxel - the time has come for me to move on from the R7800 as my needs have changed, so just wanted to say a last thanks for the work on this over the years. I've fallen a bit out of the loop so probably only updated 1 in every 4 or so updates, but this thing has been rock solid for me and I pass it onto someone with the knowledge that is runs this firmware and should continue to do so! :)
 

ianvajra

Occasional Visitor
Just set both nvram variables:

Code:
nvram set disable_dnsmqasq=1
nvram set disable_dnsmasq=1
nvram commit

Later (next release) this typo disable_dnsmqasq could be unset.

Voxel.
I figured out in the end that I could do this via Putty, after switching on Telnet in the debug pages of the routers.

I made the change (by just inputting the three lines via Telnet, one ofter the other) in both router and AP - but then had problems with DNS on some established peripheral devices - e.g. mobile phone was connected with no internet. Haven't the skills to trace the issue to source - but rolled back to 88 which didn't resolve the problems; and reset the router and set it up again to get internet connectivity as before.

I'm sure it'll be fine with Voxel 90 :)
 
Last edited:

NetBytes

Regular Contributor
I figured out in the end that I could do this via Putty, after switching on Telnet in the debug pages of the routers.

I made the change (by just inputting the three lines via Telnet, one ofter the other) in both router and AP - but then had problems with DNS on some established peripheral devices - e.g. mobile phone was connected with no internet. Haven't the skills to trace the issue to source - but rolled back to 88 which didn't resolve the problems; and reset the router and set it up again to get internet connectivity as before.

I'm sure it'll be fine with Voxel 90 :)
*ONLY* set this(these) variable on the R7800 you are using as an AP.
*NOT*,*NEVER* on an R7800 you are using as the Router. If you did set them on the Router mode R7800, unset them.
 

Armitage

Occasional Visitor
I seem to have an issue with UPNP. I can only assume this is something to do with the Router, I don't know much about how NAT works but UPNP and port forwearding all seems fairly straight forward to me so I'm not sure if I'm doing something majorly wrong here or if there truly is an issue in the firmware.

Basically I want to open a handful of ports for a game I'm playing online (quick note; it's Wreckfest, and I'm running Windows 10). I use a command line tool to do this on the PC the game runs on because I've never been happy with the R7800's port forwarding options, mainly I want to close them when I'm not running the game and to do that I'd have to delete the rule in the router - there's no on/off switch, so I have to create the rule again to 'turn it back on' and coupled with having to log into the router to do it all anyway it just makes it a bit of a hassle. The tool I use works much quicker and simpler. I run it, it opens the ports I've got set. Nice and quick.

When I run it it appears to work too. The R7800 shows this in the logs;

Code:
[UPnP set event: add_nat_rule] from source 192.168.1.3, Wednesday, November 24, 2021 15:19:40

If I go into Advanced > UPNP I can see the ports all listed too:
Capture.PNG

However the game (actually a game dedicated server) cannot see the outside world, and no one can connect to it because it doesn't show up in the server browser as if none of the ports are opened.

This is not a Windows Firewall issue BTW, I've tried doing this with and without the game added to the firewall rules to allow connections and it makes no difference. The only way I can get it to work is if I use the R7800's port forwarding option (which, as I've said, I don't want to do). If I add the ports I want to open as a rule, it works perfectly. The game can be seen in the server browser and connected to.

I did think maybe I could troubleshoot this using one of those websites that you can use to check to see if any ports are open, like canyouseeme.org, but if I enter the port into that it fails and says it's closed regardless of if I use the UPNP tool or if I just set it up port forwarding in the router so I'm not sure what's going on there.

Anyone got any clues?
 

Luizk

Occasional Visitor
The only way upnp works for me on xbox with r7800 is auto dns and auto ip. dont use any ip or dns manual on pc or gaming device if u want an open nat. Idk if this works for u. :)
 

Armitage

Occasional Visitor
I do, for the most part, let everything configure itself automatically. And everything else does seem to work fine; I've played and hosted games on consoles and the PC before with different games and they all worked. It's just this one in particular (wreckfest) which has notoriously shirte dedicated server software and you have to pretend like it's 2005 and open ports to get it to work. Just seems a bit weird how it does work if I use port forwarding and open the ports permanently in the router, but it doesn't work when I open the ports using UPNP from the PC's end even though the router shows the ports in the UPNP table suggesting it apparently pretended to open them (but clearly didn't).

I mean although I say I've played other games online (connecting to and hosting servers) without needing ports opened before, I don't know if those games even use UPNP (they may not need to, suppose it depends how they work). I have come across a post on netgear's forums regarding firmware 1.0.2.68 for the R7800 where it's claimed UPNP was broken. I'm probably wrong in this assumption but maybe if it was broken in that firmware and was never fixed, and voxels firmware inherited the broken UPNP, and it just happens that I've never had a need for UPNP until now.:confused:

It's not the end of the world for me, in fact it's pretty much first world problems. As long as port forwarding works I'll just use that. Shame there's no checkbox to enable/disable the forwarding rules.
 

karth

New Around Here
I am running an old dd-wrt by kongat that has been working fine. It was finicky for a long while for IPv6, but that is mostly working now (sometimes I have to manually start it). Unless there are security concerns I am not aware of, the only thing I'd like is the OpenVPN capability. I wouldn't mind the USB ports working for simple NAS, but I don't see whether that is enabled with this.

Do I need to revert to OEM firmware, or can I use the firmware upgrade screen within dd-wrt? I'm always scared to do a firmware upgrade on my router.
 

RMinNJ

Regular Contributor
I'd probably flash to oem first and do a power cycle/reset... just because most people upgrade from that. Other may way in if its a direct flash is ok.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top