Voxel Custom firmware build for R7800 v. 1.0.2.94SF

Voxel

Part of the Furniture
Continuation of

. . .
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-92sf.77498/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-93sf.78318/

New version of my custom firmware build: 1.0.2.94SF.

Changes (vs 1.0.2.93SF):

1. Toolchain: GCC is upgraded 11.2.0->11.3.0.
2. Toolchain: Go is upgraded 1.18->1.18.1.
3. Toolchain: GDB is upgraded 11.1->11.2.
4. libmnl package is upgraded 1.0.4->1.0.5.
5. libnfnetlink package is upgraded 1.0.1->1.0.2.
6. libreadline package is upgraded 8.1->8.1.2.
7. libjson-c package is upgraded 0.15->0.16.
8. libgcrypt package is upgraded 1.9.4->1.10.1.
9. libgpg-error package is upgraded 1.43->1.45.
10. popt package is upgraded 1.16->1.18.
11. libusb package is upgraded 1.0.25->1.0.26.
12. gdbm package is upgraded 1.19.1->1.23.
13. at package is upgraded 3.1.23->3.2.5.
14. haveged package is upgraded 1.9.17->1.9.18.
15. coreutils package (sort/gnu-date) is upgraded 9.0->9.1.
16. logrotate package is upgraded 3.17.0->3.19.0.
17. sysstat package is upgraded 12.4.5->12.5.6.
18. ffmpeg package is upgraded 4.3.3->4.3.4.
19. sqlite package is upgraded 3330000->3370000.
20. Upgrade 'detcable' binary from the stock V1.0.2.90.
21. Synchronize 'lua' patches and Makefile.
22. Host tools: upgrade quilt to 0.67.
23. Host tools: upgrade missing-macros to 11.

The link is:

https://www.voxel-firmware.com (thanks to vladlenas for his help with hosting).

Voxel.
 
Last edited:

microchip

Very Senior Member
I moved to a RAX43 and my R7800 is working as an AP now. Still value your work!
 

mjh17474

New Around Here
I've just tried transferring some files over to my NAS. With the previous release I was getting around 80 - 85MB/s with a very stable transfer graph, with this version I'm getting erratic transfers between 5 - 30MB/s.

1650660532762.png


The link speed usually holds 866/866 but I'm also seeing the following which seems to keep re-negotiating all over the place.

1650660822039.png


Should I be performing a full factory reset first before flashing a newer version?


Mark
 

mjh17474

New Around Here
If things are not working as intended factory reset after flashing fw helps.

It is showing 866/866 to me:

View attachment 40945

May be try to switch 5G channel. For me it is always 153. Switching congestion control algorithm can be helpful as well.

iperf results for 300/300 plan:

View attachment 40946

After some messing around, I haven't managed to get 5GHz to stabilise and after about 30 mins of booting the router, 5GHz disappears altogether. I've reverted back to v1.0.2.93SF for now and things are performing the way they were. I'll do some more testing over the weekend and see if I can get it stable :).
 

mjh17474

New Around Here
If things are not working as intended factory reset after flashing fw helps.

It is showing 866/866 to me:

View attachment 40945

May be try to switch 5G channel. For me it is always 153. Switching congestion control algorithm can be helpful as well.

iperf results for 300/300 plan:

View attachment 40946

Just a follow up to say after a reflash to .94SF and a factory reset. All is back to normal, not sure what happened before but all is looking good. Thanks for the suggestions! :)
 

Bati

New Around Here
I just updated to .94SF and again all went smoothly. Thanks for the update!

I noticed the following. Previous versions of the firmware showed that my GUI Language Version was behind and on v1.0.0.3##, not sure about the last two digits. Updating always failed. I tried to update again after upgrading to .94SF and now it did update to V1.0.0.425.
Is there any relation to the Voxel firmware whatsoever? What else might have caused the issue?
 

HELLO_wORLD

Very Senior Member
I just updated to .94SF and again all went smoothly. Thanks for the update!

I noticed the following. Previous versions of the firmware showed that my GUI Language Version was behind and on v1.0.0.3##, not sure about the last two digits. Updating always failed. I tried to update again after upgrading to .94SF and now it did update to V1.0.0.425.
Is there any relation to the Voxel firmware whatsoever? What else might have caused the issue?
I never paid attention to that, but now that you mention it, it offers me an update.
Not sure it matters or not, at least not for the functionality of the router. Maybe better translations for other languages?
Capture d’écran 2022-04-24 à 15.47.32.png
 

Kitsap

Occasional Visitor
Dirty update to V1.0.2.94SF went smoothly. After the update was complete and it rebooted, checked the firmware update assistant and an update to the GUI Language to V1.0.0.425 was offered. Accepted and the update completed.

Thank you to @Voxel !

So far no complaints and I do not expect any problems. However, it has only been up and running for about 20 minutes.
 

HELLO_wORLD

Very Senior Member
I'm still on .92 and I am offered the same gui update @Bati.
Is more investigation needed before I apply this so we know what's in it?
Anybody?
I applied it. It does not restart or even cut the wifi…

I think it just updates some language packs for the web gui.
 

Bati

New Around Here
I'm still on .92 and I am offered the same gui update @Bati.
Is more investigation needed before I apply this so we know what's in it?
Anybody?
I'm not sure when it first popped up. I'm quite sure I tried to update it with at least .91 through .93, all failing. Like said today after upgrading to .94 it suddenly also updated this.
I should have put a bit more effort into investigating this in all fairness. My mind just wasn't up to it today.
 

fossil

Regular Contributor
GUI Language Version Update
It will download language table (language translations). It reads information from /tmp/fileinfo.txt. It hits NG servers at:
[OR]​
Current "UI language version" and "selected UI language table" are stored in /tmp/lang_version and /tmp/lang_url files respectively.

Once you select "Check" and hit "Yes" to update the GUI Language version from UI. It will download the language table file and untar it in "/tmp/multi_lang" folder. File naming convention is bit funny from NG as usual, the main language table file name is "languages_nonEnglish.js". It is funny because same file is also used to store English language table.

Why it was not downloading it earlier?
There was some discrepancy in language table files md5 checksums on NG servers and /tmp/fileinfo.txt. NG has fixed this on their servers recently.


I believe now whichever fw version you are on if you try to update the GUI language. It will update the GUI language.

Download language table without Updating GUI Language version in UI
If you want to download and test the contents of GUI language update without updating it from UI. You can directly download the respective language table from below URL:


It will download a gzip file without extension for the provided language. You can find and replace your preferred language file (R7800-V1.0.0.425Eng-Language-table) in above url by looking at /tmp/fileinfo.txt
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top