Custom firmware build for R9000/R8900 v. 1.0.4.43HF

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Voxel

Very Senior Member
Continuation of:

https://www.snbforums.com/threads/custom-firmware-build-for-r9000.40125/
. . .
https://www.snbforums.com/threads/custom-firmware-build-for-r9000-r8900-v-1-0-4-41hf.64388/
https://www.snbforums.com/threads/c...9000-r8900-v-1-0-4-42hf-v-1-0-4-42-1hf.64841/

New version of my custom firmware build: 1.0.4.43HF.

Changes (vs 1.0.4.42.1HF):

1. Toolchain: GCC is upgraded 9.3.0->10.2.0.
2. Toolchain: Go is upgraded 1.14.4->1.14.6.
3. QoS DB is updated to 1.80 (Mar. 2020).
4. net-lan init script bug is fixef (thanks to kamoj ).
5. wireguard package is upgraded 1.0.20200623->1.0.20200712.
6. libjson-c package is upgraded 0.13.1->0.14 (including fix of CVE-2020-12762).
7. proftpd package is upgraded 1.3.6d->1.3.6e.
8. iperf3 package is upgraded 3.7->3.8.1.
9. stubby package is upgraded 0.2.6->0.3.0.
10. haveged package is upgraded 1.9.12->1.9.13.
11. sysstat package is upgraded 12.2.1-12.2.2.
12. libubox package is upgraded 2020-05-25->2020-07-11.
13. libgcrypt package is upgraded 1.8.5->1.8.6.
14. libevent package is upgraded 2.1.11-2.1.12.
15. ffmpeg package is upgraded 3.4.7->3.4.8.
16. libvorbis package is upgraded 1.3.6->1.3.7.
17. bridge-utils package is upgraded 1.6->1.7.
18. px5g package: Makefile is changed to provide compilation by GCC 10.2.0
19. transmission package: Makefile is changed to use libevent 2.1.12.

The link is:

https://www.voxel-firmware.com (thanks to vladlenas for his help with hosting).

Voxel.
 

Paul Connolly

New Around Here
Continuation of:

https://www.snbforums.com/threads/custom-firmware-build-for-r9000.40125/
. . .
https://www.snbforums.com/threads/custom-firmware-build-for-r9000-r8900-v-1-0-4-41hf.64388/
https://www.snbforums.com/threads/c...9000-r8900-v-1-0-4-42hf-v-1-0-4-42-1hf.64841/

New version of my custom firmware build: 1.0.4.43HF.

Changes (vs 1.0.4.42.1HF):

1. Toolchain: GCC is upgraded 9.3.0->10.2.0.
2. Toolchain: Go is upgraded 1.14.4->1.14.6.
3. QoS DB is updated to 1.80 (Mar. 2020).
4. net-lan init script bug is fixef (thanks to kamoj ).
5. wireguard package is upgraded 1.0.20200623->1.0.20200712.
6. libjson-c package is upgraded 0.13.1->0.14 (including fix of CVE-2020-12762).
7. proftpd package is upgraded 1.3.6d->1.3.6e.
8. iperf3 package is upgraded 3.7->3.8.1.
9. stubby package is upgraded 0.2.6->0.3.0.
10. haveged package is upgraded 1.9.12->1.9.13.
11. sysstat package is upgraded 12.2.1-12.2.2.
12. libubox package is upgraded 2020-05-25->2020-07-11.
13. libgcrypt package is upgraded 1.8.5->1.8.6.
14. libevent package is upgraded 2.1.11-2.1.12.
15. ffmpeg package is upgraded 3.4.7->3.4.8.
16. libvorbis package is upgraded 1.3.6->1.3.7.
17. bridge-utils package is upgraded 1.6->1.7.
18. px5g package: Makefile is changed to provide compilation by GCC 10.2.0
19. transmission package: Makefile is changed to use libevent 2.1.12.

The link is:

https://www.voxel-firmware.com (thanks to vladlenas for his help with hosting).

Voxel.
Hi Voxel



I am tring to create a guide that is step by step but I too am facing issues with things that don´t quite work as per the current readme,

1. Do I have to install ssh and Entware to get the optimized OpenVpn Client download speeds
2. SSH Install I want to be able to use user name and paword I don´t want want to create RSA keys etc.
3. SSH Install is this the current link to download https://www.voxel-firmware.com/Downloads/Voxel/setssh.tar ?
3) Prepare USB stick with ext2 filesystem and untar setssh.tar in the root of stick (keeping +x filemask (!) for autorun/scrips/post-mount.sh script, computer with Linux is recommended).
Is this still accurate

To create usb I followed

1) Prepare new USB stick or disk with ext2 or ext3 or ext4 filesystem from console. Label it “optware”. Ext4 is highly recommended for USB HDD. Example to create ext4 filesystem with label “optware”:

mkfs.ext4 -L optware -O ^64bit /dev/sda1
(IMPORTANT: additionally to mkfs.ext4 use the command
tune2fs -O ^metadata_csum /dev/sda1
for routers with kernel < 3.6, such as R7500/R7800)
(this simply did not work for me with USB and SSD ,I had to use https://www.diskgenius.com/?from=dg
on windows 10 to create the EXT4 partition
2) Untar entware-cortexa15-3x-initial.tar at the root of your stick/disk.

After you untar at the root of optware do you still have then download and run https://www.voxel-firmware.com/Downloads/Voxel/Entware/installer/generic.sh ?

Is it possible to move out of date files into folder labelled old or something like that?
remove out of date instructions?
 

Supersaiyan_IV

Occasional Visitor
Hi Voxel,

Congrats on the GCC 10.2.0 upgrade!
Noticed something about this, and previous version(s). Getting "[Internet connected]" twice an hour, and sometime accompanied with 5GHz wifi reset. Note that the R9000 doesn't reboot, but there's a regular, albeit brief, loss of connectivity. Does anyone experience any similar issues?

Thank you for your work on both R7800 and R9000 Voxel!
 

VinnyJ

New Around Here
From your post it sounds like your DHCP lease is set to 30 minutes.

I had something similar few months ago, I hope it helps you.
I don't believe the router is the direct cause, it's just respecting what it's receiving from the modem.

(My set-up is a Fiber gateway + R8900 router connected to it via ethernet.)
My issue was I would get random loss of connection with spam of [Internet Connected] every 5 minutes in the logs.
I remember having to extend the DHCP lease on the modem, and refresh the Netgear router to get the new change.

Go into your modem's settings through its local ip.
(On some leased devices, there's a sticker with this information.)

Look for a section that can let you change the DHCP lease.
I changed the lease length from 5 minutes to 24 hours.
(You can change yours from 30min to something even longer, if you wish.)

Back on your router, do a Release/Renew on the router from the popup from pressing the "Connection Status" button. (Advanced Tab -> Advanced Home -> Internet Port)

The router will inherit this new change.
Your problems should stop now.
 
Last edited:

Supersaiyan_IV

Occasional Visitor
From your post it sounds like your DHCP lease is set to 30 minutes.

I had something similar few months ago, I hope it helps you.
I don't believe the router is the direct cause, it's just respecting what it's receiving from the modem.

(My set-up is a Fiber gateway + R8900 router connected to it via ethernet.)
My issue was I would get random loss of connection with spam of [Internet Connected] every 5 minutes in the logs.
I remember having to extend the DHCP lease on the modem, and refresh the Netgear router to get the new change.

Go into your modem's settings through its local ip.
(On some leased devices, there's a sticker with this information.)

Look for a section that can let you change the DHCP lease.
I changed the lease length from 5 minutes to 24 hours.
(You can change yours from 30min to something even longer, if you wish.)

Back on your router, do a Release/Renew on the router from the popup from pressing the "Connection Status" button. (Advanced Tab -> Advanced Home -> Internet Port)

The router will inherit this new change.
Your problems should stop now.
Thanks for your input.

Telneted to R9000 first time, poked around a bit, and found that lease time is already 86400 seconds, which equates 24h.
Bash:
[email protected]:/$ cat /tmp/udhcpd.conf
pidfile /var/run/udhcpd.pid
start 192.168.1.2
[email protected]:/$ cat /tmp/udhcpd.conf
end 192.168.1.254
interface br0
remaining yes
auto_time 5
lease_file /tmp/udhcpd.leases
option subnet 255.255.255.0
option router 192.168.1.1
option dns 192.168.1.1
option lease 86400
Saw 'WAL_DBGID_DEV_TX_TIMEOUT' and 'out-of-sync' messages in /var/log/log-message:
Bash:
[email protected]:/$ cat /var/log/log-message
744064:[wifi0] FWLOG: [90796072] WAL_DBGID_DEV_TX_TIMEOUT ( 0x4, 0x1 )
744064:[wifi0] FWLOG: [90796374] vap-0 AP PS: AID=3 detected out-of-sync now=761885014 tx_waiting=761874076 txq_depth=4
Don't think the wifi disconnects are WAL_DBGID_DEV_TX_TIMEOUT related, because it looks like they happen even when Wifi connectivity isn't affected. However, 'out-of-sync' msgs seem more related:
Bash:
[email protected]:/$ cat /var/log/log-message | grep TX_TIMEOUT | wc -l
58
[email protected]:/$ cat /var/log/log-message | grep out-of-sync | wc -l
9
Beginning to suspect that certain misbehaving wifi clients, with buggy wifi chips or drivers, make R9000 crap itself when in 160MHz mode. Will verify this, and update post later.

EDIT:
Disabling 160MHz resolved all Wifi connectivity interrupts.
1596479092124.png


Occurrences of TX_TIMEOUT are gone. Which means that this was causing the connectivity issues:
Bash:
[email protected]:/$ cat /var/log/log-message | grep TIMEOUT | wc -l
0
Still a few 'out-of-sync' messages, which don't affect connectivity in any way:
Bash:
[email protected]:/$ cat /var/log/log-message | grep out-of-sync | wc -l
2
Conclusion: R9000 in 160MHz mode is basically unstable. Disable it.
Reasoning: When 160MHz works, it works great with quadband AX201, awesome speeds. But there's no point in using it if WAL_DBGID_DEV_TX_TIMEOUT will regularly cause the wifi connectivity to crap its pants, disconnect, then reconnect. This R9000 has: 2.4GHz disabled, 60GHz disabled, one 5GHz network enabled on 100(P)+104+108+112 EU region. Not using any of the fancy features at all, except 160MHz, which apparently doesn't work.
 
Last edited:

Supersaiyan_IV

Occasional Visitor
After another 5 days of testing with '160MHz bandwidth in the 5GHz band' disabled. I am now 100% convinced that using 160MHz causes WAL_DBGID_DEV_TX_TIMEOUT problems, leading to internet connectivity loss.

During these 5 days with 160MHz bandwidth setting disabled, I lost connectivity only once, and that was due to router changing DFS channel from 100(P)+104+108+112 to 52+56+60+64(P) - which is completely normal.

Netgear should look more closely into WAL_DBGID_DEV_TX_TIMEOUT messages caused by 160MHz bandwidth mode. This affects both R7800 and R9000.
 

xTe22-pT

Occasional Visitor
Hi Voxel,

Been using this latest version for an week, and honestly it still keeps randomly crashing and rebooting.
Last stable version for me was 1.0.4.40HF. The problems started once I updated it to 1.0.4.41HF and been happening from there on till this latest version.
I still did not figure out why the reason for thoses crashes, but I have tried all options including unmarking the Traffic metter option, but did not solve for me.
Have you made any major mods between 1.0.4.40HF to 1.0.4.41HF ? This is just to try to connect somthing that might be causing those problems.

Cheers
 

Voxel

Very Senior Member
Hi Voxel,

Been using this latest version for an week, and honestly it still keeps randomly crashing and rebooting.
Last stable version for me was 1.0.4.40HF. The problems started once I updated it to 1.0.4.41HF and been happening from there on till this latest version.
I still did not figure out why the reason for thoses crashes, but I have tried all options including unmarking the Traffic metter option, but did not solve for me.
Have you made any major mods between 1.0.4.40HF to 1.0.4.41HF ? This is just to try to connect somthing that might be causing those problems.

Cheers
There was significant changes in 39SF. But not in 40-41... My router is working fine with latest 43HF.

Do you have QoS enabled? Do you use Plex?

Voxel.
 

xTe22-pT

Occasional Visitor
There was significant changes in 39SF. But not in 40-41... My router is working fine with latest 43HF.

Do you have QoS enabled? Do you use Plex?

Voxel.
Hi,

Actually I never had none of these two options enabled.

Just forgot to mention that also have the latest beta version of Kamoj add-on installed.

I do believe the issue is not coming from there to be honest.

But also realised, sometimes it is just loosing wifi connection without rebooting. Really not sure why it is causing such issues.
 

Voxel

Very Senior Member
Just forgot to mention that also have the latest beta version of Kamoj add-on installed.

I do believe the issue is not coming from there to be honest.
IMO you should check w/o add-on as well. There could be problems not in add-on itself but say in NAND memory of your R9000 used by add-on. For example there is some specific issue with one of my R9000. Visible even when using stock.

Voxel.
 

xTe22-pT

Occasional Visitor
IMO you should check w/o add-on as well. There could be problems not in add-on itself but say in NAND memory of your R9000 used by add-on. For example there is some specific issue with one of my R9000. Visible even when using stock.

Voxel.

Yeah I understad your point, and what I can tell you is, issues appear to be showing up with a less frequency, nevertheless still getting some. Will try to remove add-on to figure out how it looks, as you recommend to do.

Funny thing here is, sometimes I got Wi-Fi disconnected at exactly 12 PM and again at 12 AM. Even without having a full crash. Not very often, but I am getting this sometimes.

This is why I hate to get occasional random issues, as they are quite hard to get fixed. And hard to understand where is the real source of the problem.
But like I previously mentioned, they started exactly in the moment I updated from 1.0.4.40HF to 1.0.4.41HF.
Anyway, going to test router without the add-on installed to see.

Cheers,
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top