DDNS and DNSOMATIC Not Working

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

willm

New Around Here
Router: RT-AC86U firmware 384.19
Running amtm diversion spdmerlin ntpmerlin and X3mrouting

Recently I have been getting an error on my DDNS connection to DNSOMATIC. When I say "recently" I noticed it for the first time a few weeks ago, but I can't say for sure when it started. I also don't use my DDNS very often while I work from home. So it isn't too inconvenient for the time being.

exclamation mark.JPG

I see "Request error! Please try again." on the DDNS page.

DDNS Page.JPG

Trying to debug it I have checked my dnsomatic username and password on the dnsomatic website and there is a message that dnsomatic now uses the opendns servers for authentication. DNSOMATIC notification

My username and password is the same for both opendns and dnsomatic, so that does not seem to be the problem. There is also a notice about usernames not being accepted for login, only email addresses, so I have tried that - also to no effect.

My syslog has the following each time I hit the apply button:

Feb 20 10:38:11 rc_service: httpd 1288:notify_rc restart_ddns_le
Feb 20 10:38:11 custom_script: Running /jffs/scripts/service-event (args: restart ddns_le)
Feb 20 10:38:11 start_ddns: update WWW.DNSOMATIC.COM [email protected], wan_unit 0
Feb 20 10:38:11 custom_script: Running /jffs/scripts/service-event-end (args: restart ddns_le)
Feb 20 10:38:11 inadyn[1077]: PID file /var/run/inadyn.pid already exists, inadyn already running?

I haven't seen any threads that involve inadyn already running, so I now look to the community to give me a few suggestions.

Thanks in advance
 

JohnD5000

Senior Member
I had a similar issue. Tried installing 386.1 386.2 alpha, resets,etc. Only thing that worked was changing my DNS from Cloudflare to Quad9. I have DoT setup and was using Cloudflare for the DNS-over-TLS Servers. When I changed these to Quad9, DNSOMATIC worked. So, check your WAN/Internect Connection tab and see who you have setup for DNS. Try changing provider and see it that matters.
 

willm

New Around Here
Thanks for your ideas.

JohnD5000, I'm not using DoT so it may be a different issue, and I am using opendns for my dns servers.

I will try switching dns servers temporarily and, if necessary, updating to 386.1_2 at the weekend. I am still interested in hearing from anyone else who may have experienced similar issues.
 

willm

New Around Here
Dear all, today I simply gave up on my longish runtime and rebooted my router. I'm embarrassed to report that it cleared the problem.
 

L&LD

Part of the Furniture
Hi, I’m L&LD and I’m an RR'r. The last time was 3 minutes ago.

Router Rebooter. :p :D :)
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top