DDNS not working after firmware update RT-AC86U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

legolas

New Around Here
For some reason, I cannot get either firmware versions 386.1 nor 386.1_2 to work with my DDNS. Specifically, the DDNS Registration Result shows as Authentication Failed for the server, WWW.NO-IP.com. Thus, I have to use version 384.19 which still works for me. Please advise. Thank you.
 

bbunge

Very Senior Member
For some reason, I cannot get either firmware versions 386.1 nor 386.1_2 to work with my DDNS. Specifically, the DDNS Registration Result shows as Authentication Failed for the server, WWW.NO-IP.com. Thus, I have to use version 384.19 which still works for me. Please advise. Thank you.
Might be time to do a Hard Factory Reset ( https://www.asus.com/support/FAQ/1039074/ ) and manually configure. Please, do not use saved settings from a prior firmware version!
My DDNS and Lets Encrypt works well to freedns.afraid.org
 

RMerlin

Asuswrt-Merlin dev
For some reason, I cannot get either firmware versions 386.1 nor 386.1_2 to work with my DDNS. Specifically, the DDNS Registration Result shows as Authentication Failed for the server, WWW.NO-IP.com. Thus, I have to use version 384.19 which still works for me. Please advise. Thank you.

What does your system log shows?
 

JohnD5000

Senior Member
For some reason, I cannot get either firmware versions 386.1 nor 386.1_2 to work with my DDNS. Specifically, the DDNS Registration Result shows as Authentication Failed for the server, WWW.NO-IP.com. Thus, I have to use version 384.19 which still works for me. Please advise. Thank you.

Something similar was happening to me trying to connect to DNSOMATIC. Tried everything. Then, I changed my DNS-over-TLS Server List settings (on WAN/Internet Connection tab) from Cloudflare to Quad9 and it then worked fine.
 

legolas

New Around Here
Something similar was happening to me trying to connect to DNSOMATIC. Tried everything. Then, I changed my DNS-over-TLS Server List settings (on WAN/Internet Connection tab) from Cloudflare to Quad9 and it then worked fine.
I don't see any option to change DNS-over-TLS Server List settings in WAN > Internet Connection. Which router are you using?
 

JohnD5000

Senior Member
I don't see any option to change DNS-over-TLS Server List settings in WAN > Internet Connection. Which router are you using?
You probably have DNS Privacy Protocol set to none. Anyhow, try changing your DNS servers to another provider and see if that matters.
 

legolas

New Around Here
What does your system log shows?
Feb 17 16:08:13 start_ddns: update WWW.NO-IP.COM [email protected], wan_unit 0
Feb 17 16:08:13 disk_monitor: be idle
Feb 17 16:08:13 custom_script: Running /jffs/scripts/service-event (args: restart nasapps)
Feb 17 16:08:13 inadyn[2851]: In-a-dyn version 2.8.1 -- Dynamic DNS update client.
Feb 17 16:08:13 inadyn[2851]: Update forced for alias XXXXXXX.ddns.net, new IP# XXX.XX.X.XXX
Feb 17 16:08:13 iTunes: daemon is stopped
Feb 17 16:08:13 FTP_Server: daemon is stopped
Feb 17 16:08:13 wsdd2[1754]: Terminated received.
Feb 17 16:08:14 inadyn[2851]: Fatal error in DDNS server response:
Feb 17 16:08:14 inadyn[2851]: [401 Unauthorized] badauth^M
Feb 17 16:08:14 inadyn[2851]: Error response from DDNS server, exiting!
Feb 17 16:08:14 inadyn[2851]: Error code 50: Authentication failure
 

RMerlin

Asuswrt-Merlin dev
Authentication failure is most likely what it says - an incorrect username or password.

Make sure your account hasn't expired. No-IP requires monthly re-activation.
 

JemTheWire

Senior Member
As Eric says, check your login credentials. I use No-IP (paid for) and don't have an issue on my AX88U with Merlin v386.1.2
 

legolas

New Around Here
Authentication failure is most likely what it says - an incorrect username or password.

Make sure your account hasn't expired. No-IP requires monthly re-activation.
I checked all these things and everything is up to date and it still doesn’t work. It’s only working on 384.19 for me.
 

legolas

New Around Here
I got it to work now. I retyped in my login and password and now it's working fine. Thank you everyone.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top