1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

DDNS Setup Problems

Discussion in 'Asuswrt-Merlin' started by archiel, Nov 9, 2018.

  1. archiel

    archiel New Around Here

    Joined:
    Apr 17, 2016
    Messages:
    9
    I am running Asuswrt-Merlin 384.7.2 on a AC87-U
    My ISP does not provide static IP addresses
    I need to setup DDNS to setup VPN and Media Server (Slim Server) access

    I am using FREEDNS in the DDNS setup. On their site I configured an A name record under the Subdomain menu (for my new domain xxxxx.mooo.com) and then Enable Dynamic DNS which gave me a username & password pair.
    On the router I went to the DDNS page added my hostname, username and password
    The other settings were:
    Method to Retrieve WAN IP: INTERNAL
    Enable wildcard: NO
    WAN IP and hostname verification: NO
    HTTPS/SSL Certificate: Let's Encrypt (then none)

    On first use the connection was successful, but no Certificate was obtained.

    However after my IP address changed the connection failed and the general log shows
    Nov 9 10:39:00 watchdog: start ddns.
    Nov 9 10:39:00 rc_service: watchdog 260:notify_rc start_ddns
    Nov 9 10:39:00 start_ddns: update FREEDNS.AFRAID.ORG [email protected], wan_unit 0
    Nov 9 10:39:01 inadyn[2359]: In-a-dyn version 2.5 -- Dynamic DNS update client.
    Nov 9 10:39:01 inadyn[2359]: Update forced for alias xxxxx.mooo.com, new IP# xxx.xxx.xxx.xxx
    Nov 9 10:39:03 inadyn[2359]: HTTP(S) Transaction failed, error 36: Temporary network error (HTTPS send)

    I also tried to setup Let's Encrypt using the instructions in https://www.asus.com/support/FAQ/1034294 but this did not work - nothing was retrieved and Let's Encrypt was stuck on Status: Updating.
    I also did not understand the instruction "Please make sure your router can issue domain validation and certificate renewal via 80 port from the Internet." I am not running any web servers on my network, so how / where do I open this port on the router (and what do I point it to?)
    To see if Let's Encrypt was the problem I set HTTPS/SSL Certificate to None, but this did not help.
    Given the reasons for DDNS use (VPN and routing to Media Server) do I even need Lets Encrypt or other certificate?
     
  2. Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!
  3. Zastoff

    Zastoff Regular Contributor

    Joined:
    Nov 21, 2017
    Messages:
    123
    Location:
    Sweden
    Last edited: Nov 11, 2018 at 12:42 PM
    SMS786 and kvic like this.
Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!