DDNS setup

pigcanswim

Occasional Visitor
Hello,

I've setup my ddns using the WebUI but my system log always give me the following every 30sec to a minute:
Jun 13 21:54:59 RT watchdog: start ddns.
Jun 13 21:54:59 RT rc_service: watchdog 1233:notify_rc start_ddns
Jun 13 21:54:59 RT custom_script: Running /jffs/scripts/service-event (args: start ddns)
Jun 13 21:54:59 RT start_ddns: update FREEDNS.AFRAID.ORG [email protected], wan_unit 0
Jun 13 21:54:59 RT inadyn[23022]: In-a-dyn version 2.5 -- Dynamic DNS update client.
Jun 13 21:54:59 RT inadyn[23022]: Update forced for alias -, new IP# x.x.x.x
Jun 13 21:55:02 RT inadyn[23022]: HTTP(S) Transaction failed, error 36: Temporary network error (HTTPS send)
Jun 13 21:55:29 RT watchdog: start ddns.
Jun 13 21:55:29 RT rc_service: watchdog 1233:notify_rc start_ddns
Jun 13 21:55:29 RT custom_script: Running /jffs/scripts/service-event (args: start ddns)
Jun 13 21:55:29 RT start_ddns: update FREEDNS.AFRAID.ORG [email protected], wan_unit 0
Jun 13 21:55:29 RT inadyn[23475]: In-a-dyn version 2.5 -- Dynamic DNS update client.
Jun 13 21:55:29 RT inadyn[23475]: Update forced for alias -, new IP# x.x.x.x
Jun 13 21:55:31 RT inadyn[23475]: HTTP(S) Transaction failed, error 36: Temporary network error (HTTPS send)

When I am using the webui, it is able to get me my WAN IP with no problems except it keeps updating every 30 sec on my sys log.

I am a complete beginner at linux and do not know anything about it but I've tried going custom script provided on the wiki but as I'm currently double NAT, it always return me my internal IP however I think it does not update as frequent or maybe at all until I restart my router.

I have no issue with using the ddns hostname and can connect without problems.

I'm posting this up because the prompts are too frequent, too long (about 4 months long) and won't stop and I am unsure of what is happening as well.

I uploaded a screenshot of my setting on the WebUI.
Please ignore the error, it's now "Registration is successful."

Hopefully any expert can help me out on this.

Many Thanks.

note: I'm currently using WebUI.

edit: update my error and clear up confusion
 

Attachments

  • ddns.PNG
    ddns.PNG
    80.1 KB · Views: 275
Last edited:

heysoundude

Part of the Furniture
It seems to me that running DDNS on a router behind a router that's getting its WAN IP dynamically assigned may likely be contributing to what you're seeing.
Can you extricate yourself from double NAT? will your ISP allow you to bridge your router so that it simply acts as a gateway?
 

pigcanswim

Occasional Visitor
Im sorry. It seem I did not provide a proper and updated description of my problem.

I am looking at my WAN IP not internal(sorry for the confusion).

My main issue now is the fact that my router keeps prompting a update on the ddns every 30 sec or so.
 

octopus

Part of the Furniture
Hello,

I've setup my ddns using the WebUI but my system log always give me the following every 30sec to a minute:
Jun 13 21:54:59 RT watchdog: start ddns.
Jun 13 21:54:59 RT rc_service: watchdog 1233:notify_rc start_ddns
Jun 13 21:54:59 RT custom_script: Running /jffs/scripts/service-event (args: start ddns)
Jun 13 21:54:59 RT start_ddns: update FREEDNS.AFRAID.ORG [email protected], wan_unit 0
Jun 13 21:54:59 RT inadyn[23022]: In-a-dyn version 2.5 -- Dynamic DNS update client.
Jun 13 21:54:59 RT inadyn[23022]: Update forced for alias -, new IP# x.x.x.x
Jun 13 21:55:02 RT inadyn[23022]: HTTP(S) Transaction failed, error 36: Temporary network error (HTTPS send)
Jun 13 21:55:29 RT watchdog: start ddns.
Jun 13 21:55:29 RT rc_service: watchdog 1233:notify_rc start_ddns
Jun 13 21:55:29 RT custom_script: Running /jffs/scripts/service-event (args: start ddns)
Jun 13 21:55:29 RT start_ddns: update FREEDNS.AFRAID.ORG [email protected], wan_unit 0
Jun 13 21:55:29 RT inadyn[23475]: In-a-dyn version 2.5 -- Dynamic DNS update client.
Jun 13 21:55:29 RT inadyn[23475]: Update forced for alias -, new IP# x.x.x.x
Jun 13 21:55:31 RT inadyn[23475]: HTTP(S) Transaction failed, error 36: Temporary network error (HTTPS send)

I am a complete beginner at linux and do not know anything about it. I've tried going custom script provided on the wiki but as I'm currently double NAT, it always return me my internal IP.

I have no issue with using the ddns hostname and can connect without problems.

I'm posting this up because the prompts are too frequent, too long (about 4 months long) and won't stop and I am unsure of what is happening as well.

I uploaded a screenshot of my setting on the WebUI.
Please ignore the error, it's now "Registration is successful."

Hopefully any expert can help me out on this.

Many Thanks.
Use inadyn.user.name.xxxxxx.com
Username:
Password:
 

octopus

Part of the Furniture
sorry but I dont understand.. do you mean using that at hostname or something?
Sorry if i was a bit unclear.
Use:
Host name = subdomain
Username name to afraid.com account
Password to afraid.com account
 
Last edited:

pigcanswim

Occasional Visitor
Sorry if i was a bit unclear.
Use: Host name = subdomain
Username name to afraid.com account
Password to afraid.com account

I'm currently using xxxxxxxx.mooo.com right now and my settings allows me to connect to the router.
I only have issues with the frequent forced updates on the ddns when I have changed nothing.
I am trying to solve this problem because my ram always hit 90%+ usage within an hour or two.
 

heysoundude

Part of the Furniture
I'm currently using xxxxxxxx.mooo.com right now and my settings allows me to connect to the router.
I only have issues with the frequent forced updates on the ddns when I have changed nothing.
I am trying to solve this problem because my ram always hit 90%+ usage within an hour or two.

RAM is meant to be used; you have a 1GB+ swap file running on your USB with entware, etc., right? If so, you shouldn’t worry about >90% usage of your router’s RAM.


Sent from my iPhone using Tapatalk
 

pigcanswim

Occasional Visitor
RAM is meant to be used; you have a 1GB+ swap file running on your USB with entware, etc., right? If so, you shouldn’t worry about >90% usage of your router’s RAM.


Sent from my iPhone using Tapatalk

I understand but it feels like sometimes my network performance is greatly affected even with my swap being available and not really in use, a restart on the router will usually fix the problem.
 

heysoundude

Part of the Furniture
I understand but it feels like sometimes my network performance is greatly affected even with my swap being available and not really in use, a restart on the router will usually fix the problem.

What is the speed you pay your ISP for?


Sent from my iPhone using Tapatalk
 

heysoundude

Part of the Furniture
You’re a few versions behind: 384.17 is the latest release, and people are reporting that the beta of 384.18 is working brilliantly. Upgrade and see if things change??


Sent from my iPhone using Tapatalk
 

pigcanswim

Occasional Visitor
I've updated to the latest firmware but the problem is still there.

Jun 15 16:39:33 RT-AX88U watchdog: start ddns.
Jun 15 16:39:33 RT-AX88U rc_service: watchdog 1255:notify_rc start_ddns
Jun 15 16:39:33 RT-AX88U custom_script: Running /jffs/scripts/service-event (args: start ddns)
Jun 15 16:39:33 RT-AX88U start_ddns: update FREEDNS.AFRAID.ORG [email protected], wan_unit 0
Jun 15 16:39:33 RT-AX88U inadyn[17253]: In-a-dyn version 2.7 -- Dynamic DNS update client.
Jun 15 16:39:34 RT-AX88U inadyn[17253]: Update forced for alias -.mooo.com, new IP# x.x.x.x
Jun 15 16:40:03 RT-AX88U watchdog: start ddns.
Jun 15 16:40:03 RT-AX88U rc_service: watchdog 1255:notify_rc start_ddns
Jun 15 16:40:03 RT-AX88U custom_script: Running /jffs/scripts/service-event (args: start ddns)
Jun 15 16:40:03 RT-AX88U start_ddns: update FREEDNS.AFRAID.ORG [email protected], wan_unit 0
Jun 15 16:40:03 RT-AX88U inadyn[17982]: In-a-dyn version 2.7 -- Dynamic DNS update client.
Jun 15 16:40:05 RT-AX88U inadyn[17982]: Update forced for alias -.mooo.com, new IP# x.x.x.x
Jun 15 16:40:33 RT-AX88U watchdog: start ddns.
Jun 15 16:40:33 RT-AX88U rc_service: watchdog 1255:notify_rc start_ddns
Jun 15 16:40:33 RT-AX88U custom_script: Running /jffs/scripts/service-event (args: start ddns)
Jun 15 16:40:33 RT-AX88U start_ddns: update FREEDNS.AFRAID.ORG [email protected], wan_unit 0
Jun 15 16:40:33 RT-AX88U inadyn[18869]: In-a-dyn version 2.7 -- Dynamic DNS update client.
Jun 15 16:40:34 RT-AX88U inadyn[18869]: Update forced for alias -.mooo.com, new IP# x.x.x.x
Jun 15 16:41:03 RT-AX88U watchdog: start ddns.
Jun 15 16:41:03 RT-AX88U rc_service: watchdog 1255:notify_rc start_ddns
Jun 15 16:41:03 RT-AX88U custom_script: Running /jffs/scripts/service-event (args: start ddns)
Jun 15 16:41:03 RT-AX88U start_ddns: update FREEDNS.AFRAID.ORG [email protected], wan_unit 0
Jun 15 16:41:03 RT-AX88U inadyn[19093]: In-a-dyn version 2.7 -- Dynamic DNS update client.
Jun 15 16:41:04 RT-AX88U inadyn[19093]: Update forced for alias -.mooo.com, new IP# x.x.x.x

As above, its updating at every 30 seconds and I have no idea why.

Could it be something triggering the forced updates every 30 seconds?

Anybody have any ideas?
 

octopus

Part of the Furniture
Use your Username and password to afraid.com in ddns gui, not you email address and test again.
 

pigcanswim

Occasional Visitor
Hmm.. It suddenly stop triggering the force update.. But I did not use the username password. I used a fake login and it stopped triggering. Now even after putting my actual username/email and password it will not trigger. I shall give it until the end of the week and see if it forced updates triggers again.
 

octopus

Part of the Furniture
Hmm.. It suddenly stop triggering the force update.. But I did not use the username password. I used a fake login and it stopped triggering. Now even after putting my actual username/email and password it will not trigger. I shall give it until the end of the week and see if it forced updates triggers again.
You probably been rejected during to many login atempts.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top