Devices preferentially connect to 2.4GHz band suddenly

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

whippoorwill

New Around Here
Dear Friends,

I have an odd problem all of a sudden. Earlier most of my devices, most of which are new, were connecting to the 5GHz band by default. Suddenly, and I can't pinpoint what exactly caused this, but now many of them prefer to connect to the 2.4GHz band. Don't know why. After that I decided to give merlin a try, to see if it would solve the problem. I upgraded to merlin latest stable firmware on my RT-AC88u, did a factory reset of the router, and configured some simple settings like AiProtection (on), WPS (off), UpnP (off), SMB server (off), Cloudflare DNS, 160MHz band (on) and a few others but nothing major. I have been using computers and routers since several years but I can only configure some basic router settings -- not at all anything like SmartConnect etc. without help. But SmartConnect is enabled of course as I have a few kindles and older devices that work only on 2.4GHz. And I live in a very small house, so it is really beyond me why the newer ones need to connect to 2.4GHz.

To clarify, this never happened before, and 2.4GHz gives a significantly slower speed with buffering on youtube, etc. I am also not blaming it on merlin, as it started happening suddenly before I decided to install merlin.

Please forgive me if this has already been discussed before, but I looked and looked and couldn't find any answer remotely related to this on this website or the internet. I do not use proxies or a VPN. Mr modem, router, and wifi network are protected by strong passwords.

Edit: Please note that I did find one solution which was to block a device from using 2.4GHz using MAC id filtering or something, but it appears cumbersome to do so for all of them.

Also, one thing I did not do was to do a factory reset BEFORE installing merlin. Should I do that and remove merlin and check? Thanks.

Please help me. Thanks!
 
Last edited:

OzarkEdge

Part of the Furniture
Dear Friends,

I have an odd problem all of a sudden. Earlier most of my devices, most of which are new, were connecting to the 5GHz band by default. Suddenly, and I can't pinpoint what exactly caused this, but now many of them prefer to connect to the 2.4GHz band. Don't know why. After that I decided to give merlin a try, to see if it would solve the problem. I upgraded to merlin latest stable firmware on my RT-AC88u, did a factory reset of the router, and configured some simple settings like AiProtection (on), WPS (off), UpnP (off), SMB server (off), Cloudflare DNS, 160MHz band (on) and a few others but nothing major. I have been using computers and routers since several years but I can only configure some basic router settings -- not at all anything like SmartConnect etc. without help. But SmartConnect is enabled of course as I have a few kindles and older devices that work only on 2.4GHz. And I live in a very small house, so it is really beyond me why the newer ones need to connect to 2.4GHz.

To clarify, this never happened before, and 2.4GHz gives a significantly slower speed with buffering on youtube, etc. I am also not blaming it on merlin, as it started happening suddenly before I decided to install merlin.

Please forgive me if this has already been discussed before, but I looked and looked and couldn't find any answer remotely related to this on this website or the internet. I do not use proxies or a VPN. Mr modem, router, and wifi network are protected by strong passwords.

Edit: Please note that I did find one solution which was to block a device from using 2.4GHz using MAC id filtering or something, but it appears cumbersome to do so for all of them.

Also, one thing I did not do was to do a factory reset BEFORE installing merlin. Should I do that and remove merlin and check? Thanks.

Please help me. Thanks!

Your 5.0 clients my not like 160 MHz bandwidth. Try 20/40/80.

Your 2.4 only clients don't need Smart Connect band steering because they can only connect to the 2.4 band.

Reset to factory defaults after you install firmware and then configure from scratch.

See my install notes for a basic configuration... particularly the WiFi settings.

If your clients continue to connect to the wrong SSID, consider setting different SSIDs and connect them to the desired SSID... manual band steering. But this should not be necessary with Smart Connect enabled.

OE
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top