Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Did I just brick my Asus?!?

Discussion in 'ASUS AC Routers & Adapters' started by cheston, Feb 24, 2013.

  1. cheston

    cheston New Around Here

    Feb 24, 2013
    Hi, I was updating the firmware to my router it said to manually restart the router which I did. When the power returned I could no longer detect the router. The power light was now blinking looking like it was in rescue mode. I tried to use the firmware restoration and the 30/30/30 method neither worked. The firmware restoration said that the router was not in rescue mode.

    Please help!!
  2. absoluteRookii

    absoluteRookii New Around Here

    Feb 24, 2013
    To unbrick

    Good thing is ASUS has a recovery mode. Go to this link on the ASUS site

    (the link is for Windows 7, 32-bit. If this is not your configuration, just go to support.asus.com and follow the instructions)
    ...and download the firmware and the restoration utility which is dated around the beginning of February. You have to install the utility on your computer. Run it and choose the firmware file. (you will have to extract from the ZIP format first).

    Cross fingers for a no-brick result...
  3. TeHashX

    TeHashX Very Senior Member

    Jul 6, 2012
    Try this steps:
    1) On your pc set static ip, subnetmask, gateway
    2) Unplug power cable from the router
    3) Turn it on to leave all excess of power…
    4) Press the WPS button
    5) Plug the powercord back on and then, after 1 or 2 seconds, press the reset button without releasing the WPS.
    6) Wait a bit and only now release the WPS button while keeping the Reset button on.
    7) Wait a bit more and release.
    8) Wait and try to ping your router on
    9) Flash firmware again with asus firmware restoration
  4. jimbones

    jimbones New Around Here

    May 9, 2013
    @TeHashX, you are an absolute legend!

Share This Page