What's new

Difficulty Updating to latest firmware RT-AX58U_388.2_2_puresqubi.w (existing AI mesh set-up)

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Hi All,

First post here. Haven't seen this query yet in the similar thread suggestions.

I have an AX3000 (aka AX58U) which is connected to my WAN link and acts as the AI mesh router.

I have a secondary AX58U which is about 10metres away that servers as an AI mesh node.

How do I best go about upgrading both to the Merlin Firmware 388.2_2?

When I've tried, given it mentions your settings can be retained, I tried first upgrading the AI mesh node (AX58U) followed by the AX3000.

However, when trying to upgrade the firmware for the AI Mesh Node, it fails and reverts back to its existing Asus stock firmware.

Any suggestions?

Do I need to remove it from the AI mesh network, as a 'standalone' AP, upgrade to the Merlin firmware, then try and upgrade the firmware on the primary AX3000 router?

Cheers, V
Do you have the newer v2 AX58U’s? If so, that’s the issue as only v1 is supported by RMerlin.

Let me check HeadBanger. Wasn't aware there were two versions of the AX58U but I did 'just' pick that one up off Amazon, and the AX3000 which is basically the same 'base' model "AX58U" I've had for over a year.
Just checked the back of it and it is infact a V2. That explains why the firmware wouldn't update.

Thank you!

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!