1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Directing OpenVPN Server Clients to static addresses

Discussion in 'Asuswrt-Merlin' started by Matt87, Oct 15, 2018.

  1. Matt87

    Matt87 New Around Here

    Joined:
    Oct 13, 2018
    Messages:
    8
    Location:
    US, Maryland
    Little bit of a noob here, so bear with me and please forgive my poor use of terminology. Setting me straight is appreciated!

    Where I'm at so far:

    Currently have 4 server clients setup for connecting to server 1; client1-4

    Previously, I was using a TAP connection and a static mac addresses, via the TAP-adapter settings on my windows laptops, so when I connected to the router the device would be assigned a static IP address 192.168.1.xxx (How much of a security risk was this, btw?). This allowed my sync software with my NAS to work. I'm now using TUN, and it's not working because they're all on 10.x.x.x subnet. I can RDP into another windows machine on my LAN as well as access my router login, but am unable to access my NAS.

    Thought network sharing settings might be the culprit, so I tried turning everything to be on with no success. (Would prefer to keep all guest/public sharing options off, though).

    I have followed @Martineau's suggestion here, with regard to setting up firewall-start to allow pass-thru of the VPN server clients to the client VPN. Surfing remotely is now covered by my client VPN policy rules.

    My question:

    Is there anything else I need to add to firewall-start in order to allow communication between my LAN devices, and clients on server1 subnet 10.x.x.x? Maybe something in openvpn-event?

    Is there something I need to do under:
    Firewall -> General -> Inbound Firewall Rules, -or-
    VPN -> VPN Server -> Advanced Settings -> Manage Client-Specific Operations, -or-
    VPN -> VPN Server -> Advanced Settings -> Custom Configuration?

    Are there any Window's network sharing options that need special configuring to sync seamlessly while on a public WIFI? If so, what and how?

    No clue where to go from here. Your help in directing me to the proper thread would be phenomenal!

    Thanks!
     
    Last edited: Oct 15, 2018
  2. Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!
Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!