Solved Disabled Port 80 for Browser Router Login, Need to Re-enable Through SSH

zwitterion

Occasional Visitor
Similar posts for my issue:

&

Details: During my frantic clicking, I disabled router login through port 80 and it immediately kicked me out. Port xxxxxxxx:8443 does not work, nor do my other open ports for browser login.

I can SSH into my router and explore the file system, but I have no idea where to look or even how to open a file to change the config. The location on the GUI is something like Administrator/System/?

I can always factory reset but would prefer to learn more about how to change this through the backend. I'm trying to get better at this Linux stuff, it's been fascinating so far and have been really enjoying the Merlin software and features such as Diversion.
 

ColinTaylor

Part of the Furniture
I'm not sure how you manged to "disable" it as that's not an option.

Try this:
Code:
nvram set http_enable=2
nvram set http_lanport=80
nvram set https_lanport=8443
nvram set http_client=0
nvram set http_clientlist=""
nvram commit
service restart_httpd
 

zwitterion

Occasional Visitor
I'm not sure how you manged to "disable" it as that's not an option.

Try this:
Code:
nvram set http_enable=2
nvram set http_lanport=80
nvram set https_lanport=8443
nvram set http_client=0
nvram set http_clientlist=""
nvram commit
service restart_httpd
Holy crap that worked! You're a wizard. Now that I'm logged in, under Administration/System/Local Access Config -- I changed authentication method to https, but I'm still wondering why 8443 didn't work since it is set on HTTPS Lan Port
 

zwitterion

Occasional Visitor
NVM I see where I failed. I had to manually enter in the URL https://xxxxxx:8443 - I disabled it again and tested it out, it does work.

Thank you for your help, Colin.
 

iTyPsIDg

Regular Contributor
NVM I see where I failed. I had to manually enter in the URL https://xxxxxx:8443 - I disabled it again and tested it out, it does work.

Thank you for your help, Colin.
Just to clarify, it was the missing S in httpS://, correct?
 

zwitterion

Occasional Visitor
Just to clarify, it was the missing S in httpS://, correct?
That is correct, it doesn't automatically set it to secure http, you have to manually enter in https, your routers gateway address, then the colon followed by 8443. However I would like to note after trying in on port 8443 the GUI experiences some issues loading various pages, so it would be best to leave it on port 80.
 

gspannu

Senior Member
That is correct, it doesn't automatically set it to secure http, you have to manually enter in https, your routers gateway address, then the colon followed by 8443. However I would like to note after trying in on port 8443 the GUI experiences some issues loading various pages, so it would be best to leave it on port 80.
The GUI should load without any issues. Refresh your browser page and clear browser cookies/ history/ cache and try again.
 

zwitterion

Occasional Visitor
The GUI should load without any issues. Refresh your browser page and clear browser cookies/ history/ cache and try again.
Yes you're right, it is loading much better now after clearing browser cookies/cache/history. And I'm actually seeing more features available especially under the Diversion tab. Every day I'm just more and more impressed by this community and this amazing software. I think some monthly donations will be in order so I can pay my respects to all these hard working and skilled individuals that I benefit from. And I'm more than happy to post my failures to increase this data base for others (hopefully) to learn as to avoid these skilled individuals from having to correct every mistake we make.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top