Disconnect RSSI below value weirdness

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

itpp20

Regular Contributor
On 2.4g there is this setting,

Capture.PNG


However I have clients often going to -60dBm or less (>-60), but these are never disconnected.
On 5g the default is -70 and I have one client who gets kicked sometimes, now I've set this to -75 and no more disconnects.
Can anyone explain why on 2.4g there are no disconnects and on 5g there are when the threshold is passed?
 

L&LD

Part of the Furniture
2.4GHz permeates everything (much more easily than higher GHz bands do).
 

itpp20

Regular Contributor
Makes sense but there's no logic in it. A threshold should not be related to the object type it relates to.
 

L&LD

Part of the Furniture
Put another way, all that means is that the client device(s) is stronger than that threshold.
 

itpp20

Regular Contributor
Its an AP function to kick a client, the AP measures lower values then the threshold, hence the AP should kick the client (as happens on 5g) to allow the client to roam. The design simply does not work on 2.4g (and leaves it up to the client to act) which explains what I've seen on another site which I couldn't explain at the time, 5g roaming works flawlessly, 2.4g not.
 

thiggins

Mr. Easy
Staff member
It could be a flaw in the AP design, if you are not noticing any disturbance (temporary disconnects) in the connection.

The other factor is that the client doesn't have a better AP to roam TO. Typically, the roam target threshold is set 6 dB or so above the roam threshold.

Check for deauthentications in the wireless log. You'll need to know the MAC address of your client.
 

itpp20

Regular Contributor
The other factor is that the client doesn't have a better AP to roam TO.
That should not matter as this specific setting is an AP setting and AP actor, the AP never knows or cares what a client is doing. Its not like 'hey AP my rssi is too low, can you kick me so I can roam?'
In this case its 'Hey you client out there, you've reached -57 and my threshold is -55 so I'm gonna kick you!'

It literally says; "Disconnect clients with RSSI lower than".

Typically, the roam target threshold is set 6 dB or so above the roam threshold.
Then it should say so in its setting under 2.4g, which it doesn't, unlike on 5g, -70 set means at -71 you get kicked of.
 

CaptnDanLKW

Regular Contributor
In my experience, it also depends on major firmware version - if you are still on the 384 branch, which is AI Mesh 1.0, then you should see in the process list roamastd, one for each band (2 or 3 depending on if you have it enabled on each of the dual or tri bands). This helper is not smart, it does not talk with other mesh nodes or APs. Its the bouncer. You don't meet the threshold, you get kicked. You should see it taking action in the logs.
In the 386 branch, when Asus introduced AI Mesh 2.0, something changed. You can see it in the logs, even when you don't have RA enabled, there's new 'ROAMING..." entries in the log.

FWIW, Once I got AI Mesh and Smart Connect working the way I wanted back in the 384 days, you really don't want RA stepping in and dropping clients before the more intelligent steering can do it's thing, so it's disabled for me.

Check your logs and your Wireless status page for client connected times, this helps you figure out if they are being dropped or not.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top