What's new

DISREGARD POST

britchie911

Occasional Visitor
The readme.txt says I need to now use for RT-AC66U_B1 (use the RT-AC68U firmware). I tried to install the latest version of RT-AC68U firmware and got an error "wrong firmware" message.

I then tried upgrading N66U from current v 380.61 to the last/latest FW (v380.70) before upgrade to the AC68U version... but couldn't get that to install either with error saying wrong version.

I have done the FW upgrade several times before. Just got the AX88U the other day and flashed FW successfully. but now wanted to use old N66U as AP in AImesh but need FW update to do this.

Please help!

Brad
 

ColinTaylor

Part of the Furniture
You can't install the RT-AC66U_B1 (or RT-AC68U) firmware on a RT-N66U, they are completely different routers.

but now wanted to use old N66U as AP in AImesh but need FW update to do this.
The RT-N66U doesn't support AiMesh at all. Although to could use it as a simple Access Point with the limitation that it only supports n-type WiFi connections.
 
Last edited:

heysoundude

Very Senior Member
If it's not accepting the latest Merlin for that model, you might have better luck if you do a nuclear reset- take it back to factory and then try again from there.
I had a good ol' n66 for many years until it decided to retire. hopefully yours isn't as fatalistic.
If you do need another asus for extended wifi coverage and want it to be all one SSID, look at an ac68 - they must be ridiculously inexpensive by now if you're looking in the right places (and don't fall for the T-Mobile version!)
 

heysoundude

Very Senior Member
I noticed that, but also saw that you had pointed that error out in your response.
re-read my post @ColinTaylor (I'm testy today too...any chance you're also a scorpio?) - I was suggesting if it still wasn't upgrading with the correct firmware for that model, a nuke might make it work.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top