DNS Filtering brakes reddit.

lepa71

Senior Member
I have Enable DNSSEC support on my AX3000 with DNS Privacy Protocol and me also trying to use DNSFiltering CleanBrowsing Family but I can't go to reddit with those settings. If I disable DNSFiltering then everything works just fine. What am I missing?
1652457402732.png
 

ColinTaylor

Part of the Furniture
... trying to use DNSFiltering CleanBrowsing Family but I can't go to reddit with those settings.

Family Filter​

Blocks access to all adult, pornographic and explicit sites. It also blocks proxy and VPN domains that are used to bypass the filters. Mixed content sites (like Reddit) are also blocked. Google, Bing and Youtube are set to the Safe Mode. Malicious and Phishing domains are blocked.
 

lepa71

Senior Member
So I switched to Quad9 and Reddit is working but sometimes it takes a couple of times to refresh some sites. I get this from Firefox
Hmm. We’re having trouble finding that site.

We can’t connect to the server at www.pch.com.

If that address is correct, here are three other things you can try:

Try again later.
Check your network connection.
If you are connected but behind a firewall, check that Firefox has permission to access the Web.

Is DNSFiltering better or not vs AIProtection?
 

dave14305

Part of the Furniture
So I switched to Quad9 and Reddit is working but sometimes it takes a couple of times to refresh some sites. I get this from Firefox


Is DNSFiltering better or not vs AIProtection?
It’s not so much the DNS Filter, but it’s DNS Privacy (DoT) that can cause those issues.
 

dave14305

Part of the Furniture
So should I not use it?
If you have DNSFilter set Globally to Quad9, then DoT won’t be used, even though it’s still active. If Quad9 is not reliable from your location, change to something else.
 

PR3MIUM

Regular Contributor
are u using a VPN, if so i would recommend to reset it (maybe messed something up ?)
had similliar problems with quad 9, but for me they are just having a to high ping 20+
and Filter is hearing like a VPN to me :)
 

lepa71

Senior Member
If you have DNSFilter set Globally to Quad9, then DoT won’t be used, even though it’s still active. If Quad9 is not reliable from your location, change to something else.
So is this what I should do instead?
Set DNS Privacy Protocol to none and use DNSFiltering or just use AIProtection.
1652483756643.png
 

lepa71

Senior Member
are u using a VPN, if so i would recommend to reset it (maybe messed something up ?)
had similliar problems with quad 9, but for me they are just having a to high ping 20+
and Filter is hearing like a VPN to me :)
I don't have a vpn.
 

dave14305

Part of the Furniture
So is this what I should do instead?
Set DNS Privacy Protocol to none and use DNSFiltering or just use AIProtection.
View attachment 41253
My preferred setup would be to set WAN DNS Server1 and Server2 to Quad9. On the LAN DHCP page, remove any DNS servers there. On the DNSFilter page, set Global mode to Router.

Clients will use the router for DNS and have a local cache in your LAN. The router will forward client requests to Quad9 (or whatever you choose for WAN DNS). All LAN client queries will be forced to use the router and Quad9.
 

lepa71

Senior Member
My preferred setup would be to set WAN DNS Server1 and Server2 to Quad9. On the LAN DHCP page, remove any DNS servers there. On the DNSFilter page, set Global mode to Router.

Clients will use the router for DNS and have a local cache in your LAN. The router will forward client requests to Quad9 (or whatever you choose for WAN DNS). All LAN client queries will be forced to use the router and Quad9.
My WAN DNS is set to Cloudflare. I don't an option for a quad but I understand I can set it manually. What I'm trying to do is to set up myself with no DNSfilter and the rest of the family have max protection. I used clear browsing for that.
Do you use dnssec, Prevent client auto DoH, DNS Privacy Protocol at all?
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top