DNS issue when using VPN with PIA and ASUS DSL-AC68U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Paulbaker1954

New Around Here
I have come across an issue with this router I can’t understand and I am not sure whether to raise this with ASUS OR PIA.

I have the router configured as main router connecting to SKY Fibre and all works fine.

Router is running std ASUS WRT Vesion 386 which is latest firmware.

OVPN client set up using PIA instructions and the config file includes the lines

dhcp-option DNS 10.0.0.241
dhcp-option DNS 10.0.0.243

When I activate the client all is ok, DNS works and my IP is a PIA One.

Now the issue is when I deactivate the VPN client I no longer have an assigned DNS server. I can ping IP addresses so I have a WAN connection just no DNS.

I have managed to work round by assigning 8.8.8.8 as the DNS server in the ASUS LAN setup and this works ok

I am curious as to why this occurs as it should not and don’t know if this is an ASUS or PIA Issue
 

eibgrad

Very Senior Member
Sounds to me like a problem w/ the ASUS stock firmware, as if it's NOT cleaning up after itself once the VPN client is deactivated. I'm sure a reboot fixes the problem as well.

If indeed the router is NOT cleaning up after itself, and you've made those DNS changes to the openvpn config file, those are to DNS servers in the *private* IP space (10.x.x.x), which are only available over the OpenVPN tunnel while active. The better option might be to NOT specify those DNS options at all in the config file but instead define public DNS servers on the WAN (e.g., 8.8.8.8 and 8.8.4.4). Then whenever the VPN is NOT active, those DNS servers are accessible over the WAN. Whenever the VPN is active, they are accessible over the VPN.
 

Paulbaker1954

New Around Here
Thanks for reply,
I tried setting the DNS servers on the WAN side but that doesn’t seem to work for some reason. It’s ok when the router is rebooted but when the vpn is deactivated I get the same problem. It seems that the DNS is not getting picked up on the LAN side.

I have not tried not adding the PIA dns servers in the config file as I think they are needed for the vpn to work for some reason

as I said in my first post specifying the DNS server as 8.8.8.8 on the LAN side fixes the problem.

I think I will try and take this up,with ASUS as I think it’s an issue with their firmware somehow.

one other thing that is annoying is that I can only specify one DNS server in the ASUS LAN dhcp page which is odd as I would expect to be able to specify 2
 

Paulbaker1954

New Around Here
Ok this gets weirder by the day.....

Set the WAN DNS servers to 8.8.8.8 and 8.8.8.4 and the LAN one to 192.168.1.1 which is the ip of the ASUS Router.

Start vpn client and all as it should be (DNS fine and IP switches to PIA as it should)

Then deactivate vpn client and on my PC all is fine (DNS working and IP back to SKY as expected but.......

IPAD and IPHONE DNS not working but connected to internet ok. Seems like IOS behaves differently when the DNS changes after using the vpn

So only way I have managed to get all to work as it should is to set the DNS on the LAN to 8.8.8.8 and leave the WAN DNS servers as automatic.

Beginning to lose my mind here!!!!!!!!!!!

I have reported this to ASUS and awaiting a reply as still sure this is an issue with the WRT firmware
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top