What's new

DNS Leaking when connected to Ethernet

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

MonkeyB

Occasional Visitor
Hello everyone,

I am using a ASUS GT AC2900 with latest Merlin firmware installed in it. I have set up an Open VPN Config file at my home in US and currently traveling in Canada. I have successfully logged into the VPN and my IP address shows the USA IP. But when I tried to loo into the DNS leak tests I see Canada and USA servers. As this is related to my work, I want to be absolutely sure of the connection before I log into it using my work laptop.

NOTE: Surprisingly this issue is not replicated when I use Wifi to connect. But I wanted to use ethernet to get a fast stable connection. Also, this router is connected to a XD4 Mini Asus mesh node. Also, I saw another thread and changed my DNS config to "Strict" and "Exclusive". I have the same results.

Below are the screenshots of my settings and the DSN page. Please let me now what I am doing wrong. I need all my pointers to be towards USA. Any help is greatly appreciated.

Screenshot 2024-05-04 at 7.40.53 PM.png
 

Attachments

  • Screenshot 2024-05-04 at 9.58.43 PM.png
    Screenshot 2024-05-04 at 9.58.43 PM.png
    643.3 KB · Views: 74
Last edited:
pretty sure you should delete this post and change your VPN settings. With only a password to guess your VPN/router is almost compromised. Sorry but exposing your router IP address and port number is an invite for hackers to bang away at it.
 
pretty sure you should delete this post and change your VPN settings. With only a password to guess your VPN/router is almost compromised. Sorry but exposing your router IP address and port number is an invite for hackers to bang away at it.
I doubt anyone is analysing the hundreds of pictures on this site, trying to understand what they contain, and extract IP addresses. Then combine that with a password and a certificate, neither of which they have.
 
Last edited:
@MonkeyB I know you said you tried it, but I think that DNS = Exclusive would be the appropriate choice. That doesn't explain the difference between ethernet and Wi-Fi connections though.

If your VPN server router and VPN client router are both using Google for their WAN DNS try changing one or the other to something different, like 1.1.1.1.

P.S. Is the GT-AC2900 the client or the server? What is the other VPN device?
 
@ColinTaylor , I have currently set it up as "Exclusive". I tried changing the WAN of the Client (GT-AC2900) to 1.1.1.1 as you suggested by going into the WAN settings and Assigning an IP. I still see Toronto in DNS Leak test.

Also, the other router (Server) is the ASUS ExpertWifi EBG15. I currently do not have access to this. I reset my router and now both ethernet and wifi shows leaked DNS :(

Note: I tried OpenVPN on my iPhone and there is no problem at all with DNS on the phone.


Screenshot 2024-05-04 at 10.34.13 PM.png
 
Setting DNS over TLS to OFF and DNS Rebind Protection to ON.

DNS.png


Had this problem some time ago with Quad9 wich showed up as "WOODY" in the DNS Leak Test.

A other User reported that in OpenVPN the Option
Code:
block-outside-dns
maybe will also work but i used the above config in the picture.
 
Are you sure that the OpenVPN server configuration is correctly set? Can you try adding the following line to the active client conf file?

For Google DNS:
dhcp-option DNS 8.8.8.8
 

Latest threads

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!

Staff online

Top