Solved dns.msftncsi.com broken (again)

rcfw

Occasional Visitor
Hello Merlin I have an idea to put an end to this problem once and for all why don’t you add an option to add the set the Microsoft domain to the routers host file to 127.0.0.1 to prevent the router spamming requests to it since. I’ve used the method of using nram to clear the domain from the settings to stop the watch dog but not even that works anymore
 

dave14305

Part of the Furniture
Have you tried it by adding it to /jffs/configs/hosts.add? The nvram would still need to match the IP you give in your hosts file.
 

RMerlin

Asuswrt-Merlin dev
Hello Merlin I have an idea to put an end to this problem once and for all why don’t you add an option to add the set the Microsoft domain to the routers host file to 127.0.0.1 to prevent the router spamming requests to it since
Don't. This will break WAN detection, and next thing you know, everyone on the forums will be wasting their time trying to help people coming here to complain about how their router fails to reconnect properly when their ISP goes down, and "forgetting" to tell us that they had fiddled with that router's behaviour.

A number of the reports in the 386.4 beta cycle were due to such people who had manually fiddled with the nvram settings related to this, forcing me to implement some form of fallback handling for these cases (i.e. restoring a sensible default value if the user had wiped that default value).

Just let the router do its thing normally. It's like 200 bytes getting sent over UDP at your ISP's DNS server, it's not gonna be affecting your network performance in any way.
 
D

Deleted member 66328

Guest
WAN detection has been broken after RT-AX88U_386.4_alpha2-g952c6bdecc.zip I would really like to know what changed so I can fix it myself with my dual WAN connection. I did the NVRAM fix. I wiped my device twice. Something in the code has changed that was not reported. I'm on 386.3.2 because nothing else past the alpha I post works!
 

Jack Yaz

Part of the Furniture
Don't. This will break WAN detection, and next thing you know, everyone on the forums will be wasting their time trying to help people coming here to complain about how their router fails to reconnect properly when their ISP goes down, and "forgetting" to tell us that they had fiddled with that router's behaviour.

A number of the reports in the 386.4 beta cycle were due to such people who had manually fiddled with the nvram settings related to this, forcing me to implement some form of fallback handling for these cases (i.e. restoring a sensible default value if the user had wiped that default value).

Just let the router do its thing normally. It's like 200 bytes getting sent over UDP at your ISP's DNS server, it's not gonna be affecting your network performance in any way.
But my dns logs! /s
 

miroco

Regular Contributor
Despite using my rt-ax86u as an access point, dns.msftncsi.com still exists in the logs of my OPNsense box.

OPNsense Unbound Log File.png


OPNsense Gateway Monitor IP.png
 

rcfw

Occasional Visitor
Don't. This will break WAN detection, and next thing you know, everyone on the forums will be wasting their time trying to help people coming here to complain about how their router fails to reconnect properly when their ISP goes down, and "forgetting" to tell us that they had fiddled with that router's behaviour.

A number of the reports in the 386.4 beta cycle were due to such people who had manually fiddled with the nvram settings related to this, forcing me to implement some form of fallback handling for these cases (i.e. restoring a sensible default value if the user had wiped that default value).

Just let the router do its thing normally. It's like 200 bytes getting sent over UDP at your ISP's DNS server, it's not gonna be affecting your network performance in any way.
Oh okay that explains why when it’s blank it still makes requests to the domain I thought my router was broken or something
 

miroco

Regular Contributor
No windows clients on my network. I'm using Mac.

Edit: I replaced the rt-ax86u with a switch and dns.msftncsi.com disappears from the logs.
 
Last edited:

Skiron

Occasional Visitor
Read and try this:

 

rcfw

Occasional Visitor
Read and try this:

Thank you this worked I set it to 99 seconds and now it only pings every 99 seconds :)
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top