DNS-over-TLS on AX89?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Adooni

Senior Member
did you found any info that it is possible on stock AsusWRT?
It is possible for RMerlin FW but your router is not supported.
 

bbunge

Part of the Furniture
Asus is implementing DoT and DNS Filter along with some other goodies in its stock firmware. There is a Beta firmware for some routers that has these features and the last release for the AX86U has DoT/DNS Filter. So the rest will get it in time. For now you can use a Pi-Hole for DNS and set it up to use DoT. The set up is a bit techie.
 

SLK350

Occasional Visitor
did you found any info that it is possible on stock AsusWRT?
It is possible for RMerlin FW but your router is not supported.
The option is there but i dont know how to setup.

Here's a screenshot from UI.

dnsovertls.jpg
 

Tech9

Very Senior Member
You only need to add Cloudflare servers in DNS-over-TLS Server List and click Apply at the bottom of the page.

1.1.1.1 (address), cloudflare-dns.com (TLS Hostname)
1.0.0.1 (address), cloudflare-dns.com (TLS Hostname)
 
Last edited:

SLK350

Occasional Visitor
You only need to add Cloudflare servers in DNS-over-TLS Server List and click Apply at the bottom of the page.

1.1.1.1 (address), cloudflare-dns.com (TLS Hostname)
1.0.0.1 (address), cloudflare-dns.com (TLS Hostname)
Thanks, where can I check if it works?
Whats the difference between the TLS-profiles "Strict" and "Opportunistic"?
 

Tech9

Very Senior Member
There is a drop-down menu with preset DoT servers in Asuswrt Beta firmware, but I don't see it on your screenshot for some reason. This is perhaps what caused the little confusion. Is it working now?
 

SLK350

Occasional Visitor
There is a drop-down menu with preset DoT servers in Asuswrt Beta firmware, but I don't see it on your screenshot for some reason. This is perhaps what caused the little confusion. Is it working now?
All is working now, thanks for helping out.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top