dnsmasq dies because of wrong sort of IP

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

slobodan

Regular Contributor
Hi, this is about an AC68U with firmware 386.2_beta2.

dnsmasq dies because 8.8.8.8 is not an IPv6 IP address when I enable DNSFilter, Global Filter Mode: Router and reboot the router. I have IPv6 enabled (Passthrough).

It does work OK if I enable DNSFilter after the router gets working.

Here it is how it should be:
Code:
dhcp-option=dnsf8,option6:23,[0]
dhcp-option=dnsf9,option6:23,[0]
dhcp-option=dnsf10,option6:23,[0]
 

Jack Yaz

Part of the Furniture
 

dave14305

Part of the Furniture
A dnsmasq.postconf could be written to remove the bad lines if beta3 or 386.2 final are still a long way off and you need to use custom DNS Filter entries for IPv4.
 

slobodan

Regular Contributor
Correction:

Here is where it is bad:

Code:
dhcp-option=dnsf8,option6:23,[8.8.8.8]
dhcp-option=dnsf9,option6:23,[8.8.8.8]
dhcp-option=dnsf10,option6:23,[8.8.8.8]

I have edited /jffs/configs/dnsmasq.conf and now the router works.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top